I just got a new computer (HP Envy) and installed elementary OS. As you may know, a lot of HP laptops come with Intel wireless drivers and they do not work on Linux right after the installation. And mine is not an exception. I do not see wireless option in the network setting. Right now, I am connected to internet by USB tethering using my phone.

My wireless driver is Intel Wireless AC9560. I have tried many different methods online but failed. Could anyone help me get my wifi working?

p.s. I also could not install elementary tweaks on my computer. While adding the PPA, it always returned

Err:10 http://ppa.launchpad.net/mpstark/elementary-tweaks-daily/ubuntu bionic Release
404  Not Found [IP: 80]
  • 1
    For the elementary tweaks issue, you have to use phillip.scott ppa: sudo add-apt-repository ppa:philip.scott/elementary-tweaks. Use sudo add-apt-repository --remove ppa:mpstark/elementary-tweaks-daily to remove the obsolete mpstark repository.
    – Vlad
    Dec 18, 2019 at 7:53
  • This was great, thank you, I was able to have wifi following your instructions. However the web became very slow, I followed a suggestion of inactivating 802. 11n found at edivaldobrito.com.br/… and I lost the wifi! Now I can't recover it back, is there any way to reactivate 802. 11n again? This is what I made: echo "options iwlwifi 11n_disable=1?" >> /etc/modprobe.d/iwlwifi.conf Can I reverse this action?
    – pedro
    Aug 18, 2020 at 9:34

1 Answer 1


Found a bunch of issues related to your wifi adapter and Ubuntu 18.04, but these two seem promising:

Ubuntu not recognizing wifi device describes how to install the latest intel wifi drivers:

 sudo add-apt-repository ppa:canonical-hwe-team/backport-iwlwifi
 sudo apt-get update
 sudo apt-get install backport-iwlwifi-dkms

WiFi Adapter Not Found: Ubuntu 18.04 suggest a kernel upgrade to 5.3:

sudo apt install linux-generic-hwe-18.04-edge
  • I have used it on OS hera (5.1), it worked, but I get an unstable connection (much lower bandwidth than expected).
    – Kerek
    Sep 3, 2020 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.