2

My laptop dual boots Windows 10 and elementary freya. Using connectify and even cmd, I can create a WiFi hotspot in Windows. However, access point mode is not supported in freya. I tried almost every method available here without any success.

My wifi card details are (from lspci -nn)

08:00.0 Network controller [0280]: 
Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

Is there any way to create the hotspot in order to share internet with my Android phone?

2

Wireless Drivers

Whichever method you choose to create your hotspot, your wireless card will need to support either Ad-Hoc or AP mode. Examine the output of iw list and look for the Supported interface modes: section. If Ad-Hoc or AP are not listed you may have to try installing another driver as there are several for Broadcom devices. You can view the name and version of the current driver in use with the lshw -c network command.

Enable Hotspot (Ad-Hoc)

Select Network from System Settings. Select Wireless from the left hand panel. A Use as Hotspot... button will appear at the bottom of the dialog. Select it and you should now have a Wi-Fi hotspot utilising Ad-Hoc mode with your computers hostname as the SSID.

Note: By default this method will only use WEP encryption. You can modify this behavior by editing the network profile by hand.

Enter sudo scratch-text-editor /etc/NetworkManager/system-connections/Hotspot in a terminal. Replace (or comment out each line with a #) the [802-11-wireless-security] section with the following.

[802-11-wireless-security]
key-mgmt=wpa-psk
auth-alg=open
psk=<your desired WPA keye>

Enable Hotspot (AP)

There is an alternative method detailed here allowing you to set up a Hotspot utilising the AP mode of your wireless device. One downside to using this method is that you may stop seeing other networks, presumably because it doesn't 'scan' once set in AP mode.

  • I can do this without changing infrastructure to ap. Are you sure that is necessary? – Lewis Goddard Aug 1 '15 at 12:49
  • It could depend on your driver/card? After choosing the hidden network my laptop (Centrino Wireless-N 2230 / driver=iwlwifi driverversion=3.16.0-45-generic) refuses to 'connect' in network-indicator then simply cycles to the next available, unless I change that line. YMMV. – elmato Aug 1 '15 at 13:11
  • @elmato My driver doesn't support AP mode. I couldn't find any other driver that does. I tried all three methods given at the link page you mentioned. Also when I tried above mentioned method, I got stuck at step 10.Output of command 10 is given in next comment. – Ashok Vishnoi Aug 2 '15 at 7:17
  • @elmato (1/2) [_LOG_LEVEL_INFO 12:41:44.301110] Application.vala:155: Scratch version: 2.2.0 [_LOG_LEVEL_INFO 12:41:44.301161] Application.vala:157: Kernel version: 3.16.0-45-generic [_LOG_LEVEL_DEBUG 12:41:44.302075] Settings.vala:158: Loading settings from schema 'org.pantheon.scratch.saved-state' [_LOG_LEVEL_DEBUG 12:41:44.302436] Settings.vala:158: Loading settings from schema 'org.pantheon.scratch.settings' – Ashok Vishnoi Aug 2 '15 at 7:21
  • @elmato (2/2) [_LOG_LEVEL_WARN 12:41:44.302821] [dconf] failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY [_LOG_LEVEL_WARN 12:41:44.302890] [dconf] failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY [_LOG_LEVEL_DEBUG 12:41:44.303056] Settings.vala:158: Loading settings from schema 'org.pantheon.scratch.services' Unable to init server: Could not connect: Connection refused [_LOG_LEVEL_WARN 12:41:44.305189] [Gtk] cannot open display: – Ashok Vishnoi Aug 2 '15 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.