I was installing ElementoryOs on my HP Laptop. One of the most important things of a laptop is carring it arround and the wifi driver isnt working I have tried a LOT of things linux kernel, bcmwl-kernel-source etc and its still not working.

When I go to Settings then i go to System then to Firmware I see BCM43142A0 When I run lspci -vnn | grep Network I get 03:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)

When I use iwconfig I get lo no wireless extensions.

enp2s0 no wireless extensions.

1 Answer 1


Have you tried following the relevant part of this guide for the relevant version? https://itsfoss.com/fix-no-wireless-network-ubuntu/

  • It doesnt work, I have tried it
    – SrGato
    Commented Aug 14, 2021 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.