hi im still new to linux and just dual booted my hp 14-bs091tx with windows, after the installation (and when on the installation prompt) no wifi adapter showed up even when using terminal to turn on the wifi it returns with no device available

also this two showed up in lspci

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15) 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d72


is there any solution to this? thanks

  • maybe the wifi is disabled and can be made availble with keyboardcombination or hardwarebutton on the side of the laptop?
    – giel
    Sep 25, 2019 at 13:43
  • no its not theres no such a button haha, its already working tho turns out i need to install d723 driver manually. so its solved. thanks for the response Sep 26, 2019 at 2:11
  • @forevermore Please add how you solved your problem so that it helps someone else facing the problem. We love informative answers with step by step guide btw. Have a nice day 👍
    – Hasan
    Sep 27, 2019 at 6:53

1 Answer 1


It's been a while since forevermore solved his problem and, because they did not post their solution...

Install Realtek d723 WiFi

sudo apt-get install linux-headers-`uname -r`
sudo apt-get install git build-essential dkms
git clone -b extended --single-branch https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add rtlwifi_new
sudo dkms install rtlwifi-new/0.6

For extra details and other methods of installing the driver: Install Realtek d723 WiFi driver for GNU/Linux Also, more detailed instructions can be found in the driver's repository

EDIT: I used the above repository to fix rtl8822be, and also had to create a new file (sudo nano /etc/modprobe.d/r8822be.conf) containing options r8822be aspm=0...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.