I have a MacbookPro5,3 (C2D 2.66, 64 bits EFI, 8GB RAM, nVidia 9400m & 9600m GT) and I am unable to boot into elementary OS.

I have tried both with Apple's boot manager and rEFInd to no avail. I am able to select the USB drive where my Freya image is and then select either Try elementary OS or Install elementary OS.

In all cases, the blinking "e" logo shows, blinks 3-4 times, then the LCD's brightness turns to the maximum and everything hangs. I waited and waited, nothing happens, I have to reset the laptop.

What am I missing? Why can't I boot elementary?

  • Are there any boot messages if you click Esc key while booting?
    – bigbang
    Oct 11, 2015 at 14:27

3 Answers 3


I have exactly the same laptop and I had the same problem. Press e on the selected option, after quiet add nomodeset and press F10 to save changes and boot. Keep in mind that after installing Freya, the first time you boot, you 'll have the same problem. You need to install nvidia drivers (Applications > Additional Drivers) and everything will work fine afterwards.


Hmmm. My guess is there's something wrong with your iso and/or something wrong with the bootloader on the bootable usb (no kidding, right?) Try using a different program to create your bootable usb. I had to do this too.

  • I used two methods: unetbootin and the convert iso to dmg and then dd the resulting image. Same result every time. Jul 28, 2015 at 17:19

Try using Create elementary OS installer.app to create your bootable USB drive in OSX, it's available here: https://github.com/linusbobcat/create-elementary-os-installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.