8

I have been repeatedly trying to get elementary OS to boot on my PC to no avail. I have tried both unetbootin and Rufus to make my USB bootable and two different USB sticks.

Whenever I boot from the USB, it opens up a black screen with the elementary logo in the middle. I had read that sometimes it takes a while for it to boot, so I let it sit. I came back 12 hours later and it hadn't changed.

  • Press ESC when the splash screen appears and it should show the boot messages. Where does it get stuck? – elmato Dec 12 '15 at 1:52
  • It boots up and I select, "Install Elementary OS". It then goes to the splash screen and is stuck there until I turn my PC off. I have tried pressing esc, but unfortunately to no avail. – Connor Caniff Dec 12 '15 at 17:02
  • Wait, I was able to get it to stop! If I hit escape right before the logo shows up, it brings up a bunch of text. It stops on "stopping system v runlevel compatibility" and then sits there. – Connor Caniff Dec 12 '15 at 20:50
  • I think that error indicates a problem starting the xserver which could be caused by many things, though more than likely is related to graphics card drivers. What graphics card do you have? – elmato Dec 13 '15 at 6:54
  • I apologize for the late reply. The graphics card I have is a 7300 LE. I have updated the drivers with Geforce experience, so the drivers are up to date. – Connor Caniff Dec 21 '15 at 3:48
1

If you're here about a stuck logo, skip past the divider. To quickly address the OP's questions, you shouldn't have to wait longer than a few minutes at the elementary logo screen, and certainly an hour would be too long even if it's loading on an old computer. Usually this would indicate some sort of bug with the installer, which you should report/track at https://bugs.launchpad.net/elementaryos You can also test whether other live USB distros (e.g., Ubuntu) load on your system and whether yours is an elementary or hardware issue. If you have multiple operating systems on your computer, you might want to try the boot-repair live USB linked below to repair your boot grub. But on diagnosing a stuck logo:


The stuck logo is one of those indeterminate situations without a clear solution, but chances are pretty good that something is hanging in the background.

  1. Boot to your grub screen (picture below)—it either loads automatically if you have multiple operating systems, or hold down shift during boot (more info) grub

  2. Press e on your elementary entry to edit its parameters

  3. At the end of the "Linux" line, remove quiet splash, which will unhide the usual startup notices (quiet) and will show that text instead of the splash page (the glowing "e"). I also recommend adding nomodeset to that line. Usually you can just kill all of the parameters at the end of the line so it just says ro nomodeset. Don't worry about screwing up—these changes are only used for this boot and not saved. Press F10 to continue booting.
  4. If you see an error, Google it—that's the real perpetrator. If you're not seeing the boot text, your options are to (a) continue playing around with those grub boot parameters, (b) boot into recovery mode from grub to play around with your graphics card drivers and kernels as those are likely at fault, or (c) run a boot-repair live USB to rebuild your grub. I found that I needed to do a combination of the three, but you'll only be able to get more help if you can diagnose the error behind the stuck logo.
1

Before doing any of the things I say below, a fair warning: I am a Complete newbie to Linux. So any of these mess up your system, its on you :P

i think your situation could happen with either of the following.

Graphics Driver error,

To check if this is the problem, disable graphic drivers on Booting. To do this

  • go to grub menu while booting (press and hold Shift key),
  • select advanced options for elementary
  • now you will See a list of kernels both generic and recovery. the selection will be on The first one (generic)
  • press 'e' (DON'T press 'Enter' cuz that will just execute booting in to that kernel ).
  • Now you will be in a kernel editing screen. in this screen go to the line that Ends with "quiet splash"
  • type in "nomodeset" in front of it so that The line will end like "nomodeset quiet splash">> press Ctrl + X Hopefully now you will go to the login screen

Kernel problem,

To check this,

  • please go to grub menu while booting (press and hold Shift key),

  • select advanced options for elementary now you will See a list of kernels both generic and recovery.

  • Select a generic kernel other than The first one>> now your computer will boot into the login screen.

conclusion: if this works you'll have to set that kernel as your default kernel by removing rest of kernels and regenerating all hooks followed by a grub update.

# update-intramfs -u && update-grub

protected by Community May 9 at 7:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.