1
  • Macbook Pro: Early 2011 running High Sierra 10.13.6
  • Trying to install: elementary OS
  • Created bootable USB using Etcher
  • I've tried going into recovery mode and disabling SIP from the command line. This didn't help.

I partitioned the boot drive on the MBP. (750GB drive) Giving macOS 550GB and elementary OS 200GB. Once I've created the bootable USB drive, I reboot my computer, hold "option" button. I see the boot screen asking me to choose HD or "EFI USB drive". I click on the EFI icon.

I'm then presented with a bios looking menu of options and I click on "Run elementary without installing it". It then takes me to a screen with three rows of text

  • 2.699652] Couldn't get size: 0x800000000000e
  • 2.699731]MODSIGN:Couldn't get UEFI db list
  • 2.716803] Couldn't get size: 0x800000000000e

The same behavior happened on my 2009 27' iMac. I feel like I'm missing something. On a Windows machine I could tell the computer to only boot from USB, in the bios, but I don't know how to tell a Mac to do this. (Or if I even need to)

I've made sure the USB drive was formatted properly (Fat32 GUID) I've tried using a different USB drive. Same issue. I tried and failed to install Fedora 28 Workstation too.

Anyone have suggestions on how I can get High Sierra to recognize the USB drive?

-1

This may not be a traditional "I fixed it" answer, but it did solve the issue.

  1. Go to the Apple App Store
  2. Install Parallels Lite (It's free)
  3. Install all the Linux distro's you want. Including elementary. It works great.

Done.

After almost a week working on this issue... Parallels was a great 12 minute solution.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.