2

I'm trying to install on a 2006 MacBook 1,1. It's Core Duo, therefore, I have to use the 32Bits version. Also, I had to use the ISO 2 USB Efi booter for mac (https://astrofloyd.wordpress.com/2014/01/14/boot-linux-from-usb-flash-drive-on-macbook/).

Anyway, it boots and I can try the OS, I even installed a system monitor, but when I click on the installation icon it doesn't start. A round circle appears for about 1 minute, but that's it. Only once the installer opened, and after I have to select my location it went into the black screen with the blinking mouse pointer, as it has been described in some threads.

What should I do in order to get the installer working and being able to install the OS?

Thanks and cheers

3

If you're installing Elementary OS on a Macbook that already has an OSX partition, i'd recommend installing rEFIt as bootloader for switching between OSX and Elementary OS. It worked like a charm and allowed me to install a triple system boot (OSX 10.6.8, WIN7, ElemOS) on an early 2008 Macbook (Core 2 Duo).

By default, rEFIt is installed on your OSX partition. If you're installing on a blank drive, it's a bit more tricky but you'll find some leads here : http://ubuntuforums.org/showthread.php?t=1150617

If you're ok with keeping a small OSX partition, use the Apple disk utility to format your disk with 3 partitions under GUID (OSX + 1 MS-DOS for Linux + 1 MSDOS for Swap). Install OSX first, then rEFIt. Put the Elementary OS install disk in, reboot and choose the Elementary CD to boot on. You can now install Linux on the partitions you had reserved. Of course, youll' need the install tool to reformat the linux one to ext4 or btrfs, and allocate the third one as swap.

2

I agree with @Tinkerzoid, rEFIt is the way to go. However, it is discontinued, but there has been a fork called rEFInd (which is basically the same thing). There's an easy, more recent explanation for installing Linux alongside Mac OS X here: http://www.howtogeek.com/187410/how-to-install-and-dual-boot-linux-on-a-mac/

If the Linux installer doesn't continue at all, the download or the live system on the USB drive may be corrupted. You could also try to create a live USB system using http://sevenbits.github.io/Mac-Linux-USB-Loader/

2

I've read that installing rEFIt or rEFInd is the 'standard' procedure. However, my OSX wasn't booting even after reinstalling it. Therefore, I thought in bringing it back to life with Elementary.

Also, during the only time that the installer started I did format the whole drive, so at this point I only have a ext4 partition and a SWAP.

I forgot to mention that I'm installing it from a USB because the superdrive is dead :(

  • Dang, too bad you already formatted the entire drive. YOu should have been able to boot OS X at least by holding the select key when turning on the computer. So if there's no OS X anymore at all, you normally wouldn't need rEFInd either. Booting from USB shouldn't be a problem either. Have you tried starting the installation procedure directly, bypassing the live system? You can choose the option at the very beginning in the black and white GRUB menu – deesnook Mar 25 '16 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.