3

I have bad video performance in Loki. After some googling I found this hint: Cannot Install Intel Proprietary Graphics Driver and with some dirty trick (I put the Ubuntu 16.04 data in /etc/lsb-release file) installed the latest Intel video drivers.
Unfortunately after doing all this I see no change in performance.

Any hints?

3
+100

The Intel Graphics has some settings you can fine-tune to improve performance or powersavings.

Long story short, if you want the best performance create /etc/modprobe.d/i915.conf as root and add options i915 powersave=0 enable_rc6=0 enable_fbc=0 to it.

If you want more settings or a further understanding of this options just write on a terminal modinfo -p i915 .
Then, to add any extra setting just do it following the scheme of setting=number or setting=true/false (in case it's a boolean)


Source

  • Thank you for answer. Unfortunately it doesn't work as proposed here. It seems that the reading of the intel manual us unavoidable... – avp Nov 14 '16 at 20:34
  • What isn't working exactly? The settings don't work or some work but some don't?? – Maccer Nov 14 '16 at 21:12
  • I did a short test doing what you've written in this answer. There is no difference, the performance remains unacceptable. I did not dig the source at arch wiki so far. I hope I will find there anything helpful. – avp Nov 15 '16 at 9:31
  • 2
    Well, considering your CPU is from 2013 I'd say that installing the lastest intel drivers from their site is a bad idea. elementary OS has quite recent versions of everything related to graphics cards so I'm sure the problem doesn't come from that. I remember that in my laptop it was impossible to play 1080 60fps videos (from youtube using firefox) with an Intel Graphics HD 4000 but now it works just fine. I didn't update anything besides the updates that elementary pushes. If you have some time, the easiest solution would be installing elementary OS again. – Maccer Nov 16 '16 at 8:57
  • 1
    I have reinstalled Loki from scratch. The problem disappeared. – avp Nov 18 '16 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.