12

I'm experiencing performance issues with my Intel graphics card like stuttering animations, artifacts, etc.

I've attempted to resolve the issue by running the Intel Graphics Installer from 01.org, but it appears to not work due to dependency errors or an incompatible LSB Release.

How can I get the latest compatible Intel graphics driver on elementary OS and ensure the best performance?

  • I'm not sure what the problem is with the Elementary OS and graphics; I just did a clean install on an old Dell Dimension 3000 with integrated Intel Extreme Graphics 2, and video playback is VERY stuttery and youtube playback is more like a slide show instead of video. Granted, this is old hardware, but it's still a 2.6 GHz Pentium 4 with 1.25 GB of RAM, with all updates applied as of 10/5/15, and it can't even play a youtube video that worked fairly well under Windows XP? I'd prefer to stick with Elementary OS, but my kid needs to watch youtube lession plans, so I guess I'll have to explore o – user2669 Oct 6 '15 at 0:38
  • The problem is that the graphics stack currently used doesn't prioritise older chipsets performance, it tries to make modern chips work well and older chips just work. – Lewis Goddard Oct 6 '15 at 8:06
  • What is your graphics card.My Intel HD Graphics 3000 worked very smoothly in Ubuntu (I can use blender and unity 3d for Linux and also open large gimp images with very little lag) – Suici Doga Mar 6 '16 at 13:06
11

You don't need to manually install Intel drivers. elementary already provides the latest Intel driver that will work correctly with the rest of the hardware stack.

The Intel driver installer from 01.org will not work with elementary OS. They do not support elementary OS and the installer no longer supports the Ubuntu 14.04 base that Freya uses.

Make sure that you're running the latest version of elementary OS. If you installed before September 3rd 2015, then you won't have the new graphics stack included in elementary OS Freya 0.3.1. You should download a fresh copy of elementary OS from our website and perform a clean install to get the best performance.

If you're running the latest version of elementary OS and you're still experiencing performance issues, your computer may simply be too old to run elementary OS.

  • Too late sir ;) I got the tip to run sudo apt-get install '^libc6.*' , but now the graphical surface won't start. If i change to F7 it displays a blackscreen. How to fix that? :D :D – Tomblarom Sep 7 '15 at 0:11
  • This is true, Freya has the latest Intel drivers. Unfortunately Loki does not have this pleasure. Therefore despite I upvoted this answer as being completely correct for Freya, I disagree here: one who wants to have an acceptable performance of video on Loki has to somehow solve the problems with Intel drivers: elementaryos.stackexchange.com/questions/8489/… – avp Oct 4 '16 at 12:52
  • I have the latest driver. I have a 2017 Dell XPS 15. And when I use the intel HD graphics, my PC crashes every 2 minutes. NVidia driver works no problem when in high performance mode (though external monitor support is spotty). – P.Brian.Mackey Jun 8 '17 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.