I am new linux user using desktop pc with AMD Ryzen 7 3700X 8-Core Processor and AMD Radeon RX 5700, OS 5.1 Hera, Linux 5.0.0-37-generic, GTK 3.22.30.

The issue is that I cannot update my system with sudo apt update and install about 100 packages without screwing up gpu driver.

I am currently running on "fresh" elementary os install with only amd proprietary gpu driver installed from here. The system is running fine in this state. However if I run sudo apt update and sudo apt upgrade and reboot, the system becomes unusable. The mouse movement is very laggy. Watching videos on youtube was fine though.

I found out, that using lshw -c video displays that driver=amdgpu.Then I ran modinfo amdgpu and the result (in flawless lagg-less state) is filename: /lib/modules/5.0.0-37-generic/extra/amdgpu.ko.

However after I ran sudo apt upgrade the result (in laggy state) is filename: /lib/modules/5.3.0-26-generic/kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.ko. I tried uninstalling and running install script on proprietary drivers again. At 99% progress it displays WARNING: amdgpu dkms failed for running kernel. Rebooting the system and running lshw -c video -> modinfo amdgpu shows again /lib/modules/5.3.0-26-generic/kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.ko.

I went through basically every ubuntu amd rx 5700 article google could find. I tried moving firmware manually like here.

I installed Additional Drivers (sudo apt install software-properties-gtk software-properties-common) to check if I can switch between the drivers located in /kernel/drivers and /extra, but it says "no additional drivers" and displays nothing.

I tried to purge package with name something like libdrmamdgpu, but other packages have dependencies on it. Force purge made me unable to boot even to recovery mode.

Then I tried holding packages with new kernel, so I could update just the rest. It installed the new gpu driver anyway and did not allow me to change back. So I went back with Timeshift and tried to hold a few packages that looked like they could be the one installing the new /kernel/driver. Unfortunately I didn't know how to identify the proper packages and the new display driver was installed anyway.

I tried holding kernel version, running sudo apt upgrade, rebooting. Then I tried to install the proprietary driver again and the /kernel/driver/ was still the one being used.

I have spent approximately 30 hours trying to solve this issue. Posting this on forum is my last resort. If I wasn't running elementary os on my laptop without any issues I would have given up on this a long time ago and just went back to Windows, where the system was running great ("windows great" though).

1)Can anyone tell me how to update everything (even the kernel) and run the system with smooth gpu driver, where the mouse isn't lagging?

2)If this isn't possible, can anyone tell how to hold proper packages so the sudo apt upgrade does not change the gpu driver to /kernel/drivers/gpu/drm/amd/amdgpu/amdgpu.

Thank you for your reply.

1 Answer 1


This is NOT supported, but I do it on my laptop so you might very well give it a shot.

Follow instructions HERE to install Ukuu. Then run the utility and install a newer Kernel (I'm currently using 5.4.13-050413-generic).

When booting, go to the Advanced menu in GRUB and select the kernel that you just installed. Give it a test-drive and report back.



  • 1
    Aldo you are god! I have spent so much time on this and all that was really needed was one kernel update. The gpu driver is the kernel one and it is working great. I do have one more question though. This made me install another kernel and sudo apt upgrade installed another one. Even though I ran uname -r and then sudo apt-mark hold [current kernel version]. How do I uninstall older kernels? I ran sudo apt --purge autoremove but it failed with dpkg: warning: while removing fwupdate, directory '/var/lib/fwupdate' not empty so not removed. I checked and old kernels are still there.
    – S1ngl3
    Jan 27, 2020 at 22:02
  • 1
    Glad it work, make sure you 'vote up' the answer for others to use as reference. As of your question, in Ukuu, scroll down to the older Kernel(s) you want to uninstall, and hit uninstall button :) There's a PURGE button which will delete EVERY kernel but the one in use, though I wouldn't recommend using it. Also, keep the oldest kernel (original, I think 4.15? maybe) for recovery/troubleshooting purposes)
    – Mudito
    Jan 29, 2020 at 4:01
  • I was not using my desktop pc for a while so I couldn't give it a proper go, but I noticed that the lagg returns quite often for no particular reason. It is laggy for about a minute or two and then goes smooth again. I tried benchmark Heaven, but that fps were stable. I always pop up Monitor when it starts lagging, but cpu and gpu are usually at 1%. I am feeling like a hypochondriac now, but it really is noticable. Is there a way to properly diagnoze the lag?
    – S1ngl3
    Feb 14, 2020 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.