3

I finally tried to get on the Juno() ship, but I'm having a major issue in that when I boot up, I get the elementary OS logo followed by a black/blank screen.

What I can do

I can press CTRL + ALT + F1 to F6 and enter TTY mode, log in, and execute commands. I ran a sudo apt update and sudo apt upgrade this way.

I can enter the graphic interface if I put nomodeset in grub. This was a suggestion I saw often while searching for a solution. However, performance is not great, and I can't even use my monitor's resolution of 1920x1080. (Max available is 1600x1200 when I enter through nomodeset)

Hardware info

  • Motherboard: MSI MS-9818
  • Processor: Intel Core 2 Duo P9500 @2.53GHz
  • Graphics: Intel Mobile 4 Series Chipset Integrated Graphics Controller (Intel GM45 is the specific one listed in the motherboard's manual.)
  • RAM: 4GB
  • Monitor: Asus VW246H connected through the built in HDMI port

Other info

To install Juno, I also had to use nomodeset in grub on the live USB because otherwise, it would also lead me to a blank screen.

I am running a dual boot with Windows 10. Don't have a spare drive to test out a pure elementary install, but I did have Loki running fine since its release on this same hardware, drive structure, etc. before this.

Jan 29 2019 edit: Not sure how relevant or helpful this is, but I also just tried installing Ubuntu 18.04 to test if it was purely an elementary OS issue. I again had to use nomodeset on the live USB in order to be able to access the install wizard. Once installed, I am once again faced with a blank screen after the grub and logo screens. However, unlike with elementary, I can't even enter TTY mode.

That's all the relevant info I can think of at the moment. Let me know if there's any other info that might be helpful to add. Thanks in advanced.

0

When your computer starts and the Ubuntu/Elementary OS bootloader kicks in there should be some options available like "boot normally", "boot in secure mode", "Start Windows" (if the installer detected your Windows installation successfully).

Press any arrow key to stop the countdown. Then press "e" to edit the first entry ("Start Elementary" or similar). You will see the boot commands that will start Elementary OS. Look for the line with "quiet splash" in it. Go there, add your "nomodeset" before or after (shouldn't matter) and press "F10" or "CTRL + X" to execute this new boot configuration. Your system should start up normally (like it does when you use the live usb).

Now to make this changes permanent, you need to edit the grub boot config. Edit the file /etc/default/grub as root. Look for the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and add "nomodeset" before, after or between the two options (again, the position doesn't matter). When you're finished, save your changes, exit the editor and update your grub configuration:

sudo update-grub

Now your changes are permanent and should even survive a kernel upgrade.

  • I might be misunderstanding the purpose of nomodeset or I am asking the wrong question. Currently I am using nomodeset to boot as it is the only way I can get to the desktop. I though that nomodeset was a temporary workaround because it would disable other drivers which seems to be the case at the moment. I found a thread that suggested that I use glxinfo | grep OpenGL to see if my system is using the GPU or CPU to render graphics. When using nomodeset it is using the CPU and I haven't found a way to load the Intel driver. When I don't use nomodeset I am stuck at a blank screen. – illbeyourguest Jan 31 at 0:59
0

I ended up solving my own problem.

I swapped monitors to an older one that connects through VGA. I noticed that with that monitor, I was getting the desktop background image and the cursor, but nothing else. I looked around and found someone who had a similar issue and was able to solve it by pressing Super+P which would toggle between different displays. I tried that, and sure enough, after a couple presses, I had the full desktop including plank and wingpanel on the screen. I checked the display settings and could see that two displays are detected, one being detected as "Built-in Device", even though only one is hooked up. I believe this is because the motherboard has an LVDS port, but I am not sure.

Since I had been tweaking things I decided to do a fresh install to see if any of those adjustments had been necessary in the first place. To install this time around I did NOT use nomodeset on the live USB and used the old monitor connected through VGA. This time, the screen was not blank, but like before, I only had the wallpaper and cursor. I pressed Super+P a couple of times and eventually had the install wizard on my screen. I installed elementary OS with no issues, restarted, and had the full desktop. nomodeset, again, not necessary.

So now I could confirm that elementary OS was installed and working and using the proper display driver. However, when I plugged in my HDMI display, it would cut signal from my VGA monitor and the HDMI monitor itself would say "No Signal." I tried using Super+P to see if that would help, but it did not in this case. If I unplugged it, my VGA monitor would receive signal once again and have the full desktop available.

To test if the monitor was actually being detected, I typed xrandr on the terminal, connected the monitor (once again everything was blank), and pressed enter. I disconnected it again to see the results which did show that HDMI-1 had been detected as connected.

I dug around for the simplest solution I could find and eventually decided to try xrandr --output HDMI-1 --primary --mode 1920x1080 on the terminal. Like before, I typed it in in the terminal before plugging in my HDMI monitor. I plugged in the monitor (again, both monitors completely blank) and pressed enter. This did make a difference and I finally had video on the HDMI monitor. I ran xrandr --output VGA-1 --mode 1024x768 and now also had the second monitor working. I went to Settings>Display to adjust placement with no issues. I should note that the monitors are not perfectly detected. Both show up as "Ancor Communications Inc 24"" even though the VGA one is a Sony 15" monitor. In Loki, they were differentiated properly.

Any changes I made through Settings>Display did not stick so in order to force my display settings, I added the two commands (xrandr --output HDMI-1 --primary --mode 1920x1080 and xrandr --output VGA-1 --mode 1024x768) to run automatically at start up by adding them Settings>Applications>Startup. I did a reboot and everything worked okay.

The last big issue I encountered was that these settings did not apply to Greeter so whenever I logged out, both monitors were blank unless I unplugged the HDMI monitor to have video display on the VGA port. To solve this, I copied ~/.config/monitors.xml to /var/lib/lightdm/.config .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.