3

I'm using ASUS GL552VW. It has Intel HD Graphics 530, and Nvidia Geforce 960M Graphics Processors. As using intel graphics will be a power saving option for me, I was trying to install the Intel Propriety Graphics Driver in it.

Usually, it says "elementary loki" is unsupported. So I edited the /etc/lsb-release file to emulate "Ubuntu 16.04".

Now it's stuck here for a long time.

Intel Graphics Update Tool

Here is the debug info:

skb50bd@ROG:~$ intel-graphics-update-tool src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking if Intel graphics card available... src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Retrieving information from 01.org... src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking distribution... src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking kernel version... src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking available repositories... src/diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking package manager status... No LSB modules are available. polkit: Fetching org.01.linuxgraphics.update-tool permissions... Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged. src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking if Intel graphics card available... src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Retrieving information from 01.org... { errors: (nil) sources: [https://download.01.org/gfx/ubuntu/16.04/main xenial main] keys: [] docs: [] INSTALL: [] install: [i915-4.6.3-4.4.0-dkms libgles1-mesa libgles2-mesa libosmesa6 libva-drm1 libva-egl1 libva-glx1 libva-tpi1 libva-wayland1 libva-x11-1 vainfo libcairo2] upgrade: [libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa libxatracker2 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libva1 va-driver-all i965-va-driver intel-gpu-tools] lts: [] } src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking distribution... ๐Ÿ•› package_manager_is_distro_supported ๐Ÿ•› Configuration : Loading โ€ฆ [ 0 % ] โฒ { errors: (nil) sources: [https://download.01.org/gfx/ubuntu/16.04/main xenial main] keys: [] docs: [] INSTALL: [] install: [i915-4.6.3-4.4.0-dkms libgles1-mesa libgles2-mesa libosmesa6 libva-drm1 libva-egl1 libva-glx1 libva-tpi1 libva-wayland1 libva-x11-1 vainfo libcairo2] upgrade: [libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libwayland-egl1-mesa libxatracker2 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libva1 va-driver-all i965-va-driver intel-gpu-tools] lts: [] } ๐Ÿ•› package_manager_is_distro_supported ๐Ÿ•› Configuration : Loaded [ 80 % ] โฒ ๐Ÿ•› package_manager_is_distro_supported ๐Ÿ•› Configuration : Testing โ€ฆ [ 80 % ] โฒ Checking repository sources 3 >= 1 Checking package list 28 >= 1 ๐Ÿ•› package_manager_is_distro_supported ๐Ÿ•› Configuration : Complete [ ] โ—ฆ src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking kernel version... src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking available repositories... src/diagnostics-view.c/diagnostics_view_start: Running diagnostic Checking package manager status... NOTE: This is only a simulation! apt-get needs root privileges for real execution. Keep also in mind that locking is deactivated, so don't depend on the relevance to the real current situation! Reading package lists... Done Building dependency tree
Reading state information... Done src/main-window.c/on_diagnostics_finished: Diagnostics finished successfully diagnostics warning flags: 01 ๐Ÿ•› transaction_view_start ๐Ÿ•› Ensuring consistent system... : โ€ฆ [ 0 % ] โฒ src/transaction-view.c/transaction_view_start: Running transaction Ensuring consistent system... ๐Ÿ•› pre_install_transaction ๐Ÿ•› Pre-install : [ 0 % ] โ—ฆ ๐Ÿ•› package_manager_pre_install ๐Ÿ•› Pre-install : Ensuring consistent repositories โ€ฆ [ 0 % ] โฒ + [ -f /etc/apt/sources.list.d/intellinuxgraphics.list ] src/transaction-view.c/on_pm_op_finished: Package manager operation finished ๐Ÿ•› on_pm_op_finished ๐Ÿ•› Pre-install : Complete [ ] โ—ฆ ๐Ÿ•› package_manager_pre_install ๐Ÿ•› Pre-install : Complete [ ] โ—ฆ ๐Ÿ•› transaction_view_start ๐Ÿ•› Ensuring consistent system... : Complete [ ] โ—ฆ ๐Ÿ•› transaction_view_start ๐Ÿ•› Listing packages... : โ€ฆ [ 0 % ] โฒ src/transaction-view.c/transaction_view_start: Running transaction Listing packages... ๐Ÿ•› list_transaction ๐Ÿ•› List packages : [ ] โฒ

2

I had similar problem (but I have Intelยฎ HD Graphics 5500).
So thanks to your suggestion I faked the /etc/lsb-release with following contents:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

During the first time I had problems with PPAs, therefore I had to disable all sources marked as 'broken'. I have run the command sudo intel-graphics-update-tool which gave me possibility to see all broken sources in one shot.

After having done that the installation was successful with following report:

Added:
autotools-dev:all (20150820.1)
debhelper:all (9.20160115ubuntu3)
dh-strip-nondeterminism:all (0.015-1)
i915-4.6.3-4.4.0-dkms:all (1)
intel-gpu-tools:amd64 (1.15-1intel1)
libegl1-mesa-drivers:amd64 (11.2.2-0intel1)
libfile-stripnondeterminism-perl:all (0.015-1)
libgles1-mesa:amd64 (11.2.2-0intel1)
libgles2-mesa:amd64 (11.2.2-0intel1)
libmail-sendmail-perl:all (0.79.16-1)
libosmesa6:amd64 (11.2.2-0intel1)
libsys-hostname-long-perl:all (1.5-1)
libunwind8:amd64 (1.1-4.1)
libva-drm1:amd64 (1.7.1-0intel1)
libva-egl1:amd64 (1.7.1-0intel1)
libva-glx1:amd64 (1.7.1-0intel1)
libva-tpi1:amd64 (1.7.1-0intel1)
libva-wayland1:amd64 (1.7.1-0intel1)
libva-x11-1:amd64 (1.7.1-0intel1)
po-debconf:all (1.0.19)
vainfo:amd64 (1.7.1-0intel1)

Upgraded:
i965-va-driver:amd64 (from 1.7.0-1 to 1.7.1-0intel1)
libcairo2:amd64 (from 1.14.6-1 to 1.15.2-0intel1)
libdrm-intel1:amd64 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm-intel1:i386 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm-nouveau2:amd64 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm-nouveau2:i386 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm-radeon1:amd64 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm-radeon1:i386 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm2:amd64 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libdrm2:i386 (from 2.4.67-1ubuntu0.16.04.2 to 2.4.68-1)
libegl1-mesa:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libgbm1:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libgl1-mesa-dri:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libgl1-mesa-dri:i386 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libgl1-mesa-glx:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libgl1-mesa-glx:i386 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libglapi-mesa:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libglapi-mesa:i386 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libva1:amd64 (from 1.7.0-1 to 1.7.1-0intel1)
libwayland-egl1-mesa:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
libxatracker2:amd64 (from 11.2.0-1ubuntu2.2 to 11.2.2-0intel1)
va-driver-all:amd64 (from 1.7.0-1 to 1.7.1-0intel1)
| improve this answer | |

Your Answer

By clicking โ€œPost Your Answerโ€, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.