8

I created an eOS live USB and set up a dual-boot partition so I can boot into Windows 10 or eOS. The problem is that the clock on Windows is one hour behind the real time whenever I boot into Windows.

If I go to Control Panel and check and uncheck auto update then the time corrects itself, until I next go over to eOS. When I return to Windows the time is wrong again.

Edit:

If I boot into Windows and then reboot back into Windows, the time stays the same.

If the time is right in Windows and I reboot into eOS then the time on the eOS log-in screen is one hour later than the real time. Once I log-in to eOS the time corrects itself automatically. If I then reboot into Windows, the Windows time is one hour behind the true time.

It seems that eOS time is one hour ahead of Windows time. If Windows time is set to correct time the eOS time is +1 until it fixes itself. Once eOS time is fixed, Windows time becomes -1 until I correct it.

Both Windows and eOS options are set to the London time zone.

Does eOS support British Summer Time and GMT?

  • Is the issue booting back into elementary OS sets it off? Or is it rebooting the computer that sets it off? (Trying to isolate the issue) – wolf Sep 28 '16 at 17:06
  • @wolf Please see my addition to my OP. – Fly by Night Sep 28 '16 at 19:16
  • It probably has to do with the hardware clock. Windows is trying to calculate the time as the hwclock had the local time (which Windows does by default) and during the installation of Elementary it was probably set to UTC. – Ale Sep 28 '16 at 19:39
5

Windows sets the BIOS clock to the local time while Linuxes (so elementary OS as well) sets to UTC by default. You can set the hardware clock time standard through the command line. To change this default setting and to set the BIOS clock to local time instead of UTC, you will have to use the timedatectl command. You can check what you have set to use by:

timedatectl | grep local

The hardware clock can be queried and set with the timedatectl command. To change the hardware clock time standard to localtime, use:

timedatectl set-local-rtc 1

If you want to revert to the hardware clock being in UTC, do:

timedatectl set-local-rtc 0

(source: https://askubuntu.com/questions/169376/clock-time-is-off-on-dual-boot)

  • This worked perfectly. Thank you very much. – Fly by Night Sep 29 '16 at 16:46
1

reg.exe add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1 /f

will teach windows how to use utc.

source(ger): https://de.manjaro.org/index.php?PHPSESSID=q41mtgvu2164dfnqrc5q6gnl17&topic=95.msg714#msg714

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.