0

I'm quite new to the linux world. I installed elementary OS alongside win10 on the same ssd in different partitions. While installing I created a swap- home and efi partition. after a while, I tried booting back to win10 and at first it stated that the system needed repair tools and wouldn't let me progress. I burned a ISO into a usb and tried booting from there but nope. After messing a bit with the bios setting now it displays another error: "reboot and select proper boot device or insert boot media in selected boot device and press a key"

I tried messing with the bios setting, changing boot order but nothing worked. my laptop is an Asus a55v

I can boot without errors into elementaryOS but I really need win10 back as well.

here a pic of my partitions in gparted. windows is sda2 while sd1 is recovery for windows and sda3 is elementary

Thank you so much for your help and time, Jean

enter image description here

here are my bios settings

bios setting asus a55v

0

Can you get directly into the boot menu directly when you reboot? It might be F8. If so, you should see windows boot manager as one of the options. If you don't see it then something is not good.

| improve this answer | |
  • Yes I can go into boot menu and into the bios setup. I don't see windows, I only see ubuntu and the ssd where win10 is installed as another boot option, but when booting that way the "reboot and select proper boot device or insert boot media in selected boot device and press a key" displays. What if I flashed my bios ? would it help ? – Jean Mar 2 at 21:31
  • When you boot does it go straight to elementary os or do you see a grub screen? I'm limited in how much I can help as I installed my Win 10 and EOS on separate drives so I still have a EFI fat partition for each OS. I don't think flashing the BIOS will help. – riff raff Mar 3 at 1:12
  • I can access grub on startup if I press any button, or it goes directly on elementary. But even then only Elementary os pops up in grub. – Jean Mar 3 at 16:35
  • I'm out of my league at this point. There is a utility called "boot repair" that I used as a last resort once. Maybe it will work for you: fosslinux.com/1521/… – riff raff Mar 3 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.