2

I want to setup a network printer and I have the ppd file for it. How can I point to my ppd file in setup process? I tried cups web interface at localhost:631 but I got "Connection refused" answer. I inspected the config, but the "Listen localhost:631" line was not commented so I don't know where can I enable it.

  • I found installed system-config-printer which seems ok. – Zsolt Szokolai Sep 28 '16 at 8:27
  • Although system-config-printer working fine the ppd file not enough. The filter is missing must install something also. – Zsolt Szokolai Sep 28 '16 at 8:49
  • What filter do you mean? And what kind of printer is it? Is it a custom PPD or are you using the file from their website? (If you can avoid downloading drivers, might be better...) Re: CUPS web install, have you tried this guide? You need to activate a few things before trying to connect to localhost:631 – wolf Sep 28 '16 at 9:24
  • I saw errors in /var/log/cups/error_log. The type of printer is Canon imageRUNNER 1133iF, and yes, I downloaded PPD from their website. Then later I downloaded compete linux setup stuff. The setup ran with error but installed things into /opt/cel including the missing filter. Thereafter system-config-printer got the possibility to select proper ppd from install tgz. Finally I set up my printer successfully. – Zsolt Szokolai Sep 28 '16 at 10:15
1

elementary OS doesn't have an option like Ubuntu of loading directly from PPD. I would recommend instead downloading the driver directly from the manufacturer's website with their install script and following elementary's prompts.

If you would like to configure additional administrative features, run system-config-printer in your Terminal. Alternatively, you could try a CUPS web install or, if you are a glutton for punishment, CUPS install by text.

| improve this answer | |
  • I agree with you my experience took me to the same place. But your summary better and detailed. – Zsolt Szokolai Sep 28 '16 at 11:36
0

I realized there is no need the possibility the custom ppd file select if I have properly installed driver for that printer. So the elementary's config interface is perfect and nice. My question become unnecessary thank for everybody for attention.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.