2

By default, the battery notification says that shutdown is imminent at about 3% .

Can the laptop be made to suspend at this point instead of shutting down?


UPDATE:

After finding this answer, I see that low and critical battery percentage is now handled by UPower and not by gsettings and that instead of using gsettings, one should now edit the file /etc/UPower/UPower.conf

That works for editing battery levels to be considered low and critical and the level for action, but not for setting the action itself which is still shutdown, even though the line there is CriticalPowerAction=HybridSleep. That is the default anyway, and was there already.

As specified by that file:

# The action to take when "TimeAction" or "PercentageAction" above has been
# reached for the batteries (UPS or laptop batteries) supplying the computer
#
# Possible values are:
# PowerOff
# Hibernate
# HybridSleep
#
# If HybridSleep isn't available, Hibernate will be used
# If Hibernate isn't available, PowerOff will be used

Is Hybridsleep different than Sleep?

After making the changes mentioned above, I can set the critical battery percentage to take action at - but should I look for another setting on the action to take - or is Hybridsleep the only option permitted by the system (while my machine cannot use that)?

2

This setting is now handled by the Upower tool.

As indicated in /etc/UPower/UPower.conf, Upower does not support Suspend/Sleep, but instead supports Hybrid-sleep, which is a middle between hibernation and sleep. It is similar to Sleep/suspend in that it comes back to full operation very quickly because it constantly refreshes the RAM, but it also similar to Hiberantion because it 'swaps' RAM data to the hard disk and is able to restore it in case of power cut.

Because it saves RAM data to the hard disk, just like hibernation, the hybrid-sleep needs a swap partition. On my system I didn't had one, and that's why Upower used PowerOff insted. I created one swap space following this answer, and then, with the line CriticalPowerAction=HybridSleep in /etc/UPower/UPower.conf and then the computer entered hybrid sleep at the percentage set by the line PercentageAction=8.

The notifications now say "hibernate", but it is HybridSleep in fact.

enter image description here

enter image description here

So, to set percentage for this action, edit the line

PercentageAction=8

while this line should look like so:

UsePercentageForPolicy=true

To set the low and critical percentages, edit these lines:

PercentageLow=15
PercentageCritical=10

Before setting the swap space the commands systemctl hybrid-sleep and systemctl hibernate gave an error message. Now, systemctl hybrid-sleep puts the computer to sleep (which I trusted is hybrid sleep), but systemctl hibernate shuts down the system completely instead of hibernating it, that is: when I start it back the system is logged off and all my programs are closed. (This makes me think that maybe hibernation and swapping RAM data to hard disk don't work on my hardware and, although swap space is needed to use the option 'HybridSleep' in Upower settings, what happens on my system is not really Hybrid-Sleep, but just Sleep.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy