I recently upgraded to the Loki release with a fresh install on my Thinkpad S540 without much initial problems. Today I had to use a wired connection for the first time and to much surprise the ethernet port appears to be unable to detect the cable I just plugged in (works perfectly fine in another pc).

First course of action was to check whether the ethernet is recognized at all (I translated the information headers from German to English so there might be some wonky line names):

sascha@sascha-ThinkPad:~$ sudo lshw -c network -sanitize
       Description: Ethernet interface
       Product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       Manufacturer: Realtek Semiconductor Co., Ltd.
       Physical ID: 0
       Bus-Informationen: pci@0000:03:00.0
       Logical Name: enp3s0
       Version: 10
       Serialnumber: [REMOVED] //No edit from my side here
       Size: 10Mbit/s
       Capacity: 1Gbit/s
       Width: 64 bits
       Tact: 33MHz
       Abilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       Konfiguration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       Ressourcen: irq:43 ioport:4000(Größe=256) memory:f0704000-f0704fff memory:f0700000-f0703fff

Next step I tried was going to the network settings, tried getting into the advanced settings for the ethernet connection and was greeted with the following:

No connection with the UUID »« could be found

After googleing a bit and learning what an UUID is I came to the conclusion it should be assigned by the network manager (correct me if I'm wrong), so I tried purging and reinstalling the network manager however this did not solve the problem.

So this is the point where I am at at the moment and my google foo doesn't seem to get me any further. I hope some of you can help me out on this one and please let me know if you need more info.

2 Answers 2


I found this guide: https://unixblogger.com/2016/08/11/how-to-get-your-realtek-rtl8111rtl8168-working-updated-guide/

Give it a shot and see if it works :)

Edit: Here is an archive of the article


  • 2
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – RolandiXor
    Apr 11, 2017 at 17:33
  • Writing this as I'm connected to the internet via ethernet. Thanks for the link!
    – Sascha
    Apr 12, 2017 at 8:29
  • Wait, so did it work?
    – Eosdude
    Apr 12, 2017 at 18:07
  • 1
    Neither link is working. That is why @RolandiXor said the answer should include the steps and the link should only be cited for reference. I'm having the exact same problem and this answer has now been rendered useless.
    – Wheepy
    Nov 6, 2020 at 18:54

not sure if this is the same situation ... especially since I am trying to remember exactly what happened to me ... First thing first ... I was running ubuntu at work ... ran a software update ... then all of a sudden i didnt have any network.

To get the network running (I need that for work) What I did was manually edit /etc/network/interfaces and configured it for my static IP address ... it is not very complicated

  1. auto eth0
  2. iface eth0 inet static
  3. address {your IP address here}
  4. gateway {your ...}
  5. netmask {your ...}
  6. dns-nameservers {your ...} {... if multiple}

I think that was all I needed

after another software update (I think there was something "funky" about a Network Manager update) I was able to put it back that way it was and the network was working the way it was/is

  1. auto lo
  2. iface lo inet loopback

see it that helps you out or at least points you to a solution that works for you ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.