1

I can't install gazette the weather widget. I tried this:

sudo add-apt-repository ppa:gotwig/weekly
sudo apt update
sudo apt install gazette

The first and second commands worked but the third command shows this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gazette
4

The PPA you are trying to install Gazette from has not been updated to include a build for Loki (Ubuntu Xenial). It appears that the Gazette project does not offer prebuilt binaries, so your only option is to build from source.

Launchpad is currently down, so these instructions need checking.

  1. Install pre-requisite packages (check the INSTALL file for specifics): sudo apt-get install build-essential autoconf automake

  2. Grab the code: bzr branch lp:gazette

  3. From inside the project directory, generate configure file: ./autogen.sh

  4. Compile like normal: ./configure && make && sudo make install.

  • sorry but i'm a new user i just cant understand how to do – emad Sep 27 '16 at 22:01
  • @emad I'm afraid the answer is probably that you'll have to wait until someone builds Gazette for Loki then I'm afraid. – Mike Wild Sep 28 '16 at 7:43
0

You can check the ppa first to see which packages includes using synaptic.

*Detailed instructions here: HOW TO LIST PACKAGES FROM A PPA / REPOSITORY IN UBUNTU Source: http://www.webupd8.org/2012/12/how-to-list-packages-from-ppa.html?m=1

  • This does not answer the original question of how to install Gazette on Loki. – Mike Wild Sep 26 '16 at 15:13
  • For instructions about installing gazette you can try elementaryforums.com/index.php?threads/… but I haven't tried in loki. I assumed there was a problem with the repository name so I apologize if my answer could lead to confussion. – Jorge R. Marín Sep 26 '16 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.