1

I'm trying desperately to install Nuvola Player 3 (package: nuvolaplayer3).
When trying to install from terminal I get:

E: Failed to fetch https://tiliado.eu/nuvolaplayer/repository/deb/pool/devel/n/nuvolaplayer3/nuvolaplayer3_3.1.0~201608141426.c7e45b4-0+1~trusty_amd64.deb  HttpError403

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

When I download the deb package and run it opens in software centre, gets most of the way and then says the below error.

Selecting previously unselected package libjavascriptcoregtk-4.0-18:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 195971 files and directories currently installed.)
Preparing to unpack .../libjavascriptcoregtk-4.0-18_2.8.5+dfsg1-1~14.04~webkitteam1_amd64.deb ...
Unpacking libjavascriptcoregtk-4.0-18:amd64 (2.8.5+dfsg1-1~14.04~webkitteam1) ...
Selecting previously unselected package libwebkit2gtk-4.0-37:amd64.
Preparing to unpack .../libwebkit2gtk-4.0-37_2.8.5+dfsg1-1~14.04~webkitteam1_amd64.deb ...
Unpacking libwebkit2gtk-4.0-37:amd64 (2.8.5+dfsg1-1~14.04~webkitteam1) ...
Setting up libjavascriptcoregtk-4.0-18:amd64 (2.8.5+dfsg1-1~14.04~webkitteam1) ...
Setting up libwebkit2gtk-4.0-37:amd64 (2.8.5+dfsg1-1~14.04~webkitteam1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
dpkg: considering removing libjavascriptcoregtk-4.0-18:amd64 in favour of nuvolaplayer3 ...
dpkg: no, cannot proceed with removal of libjavascriptcoregtk-4.0-18:amd64 (--auto-deconfigure will help):
 libwebkit2gtk-4.0-37:amd64 depends on libjavascriptcoregtk-4.0-18 (= 2.8.5+dfsg1-1~14.04~webkitteam1)
  libjavascriptcoregtk-4.0-18:amd64 is to be removed.

dpkg: regarding .../nuvolaplayer3_0.20160613-Bundle1.for.Ubuntu.14.04.Trusty.Tahr_amd64.deb containing nuvolaplayer3:
 nuvolaplayer3 conflicts with libjavascriptcoregtk-4.0-18
  libjavascriptcoregtk-4.0-18:amd64 (version 2.8.5+dfsg1-1~14.04~webkitteam1) is present and installed.

dpkg: error processing archive /home/skywalker/Downloads/nuvolaplayer3_0.20160613-Bundle1.for.Ubuntu.14.04.Trusty.Tahr_amd64.deb (--install):
 conflicting packages - not installing nuvolaplayer3

I run sudo apt-get remove libjavascriptcoregtk-4.0-18:amd64 due to the conflict but when I re-run the install after (either way) I get the same errors. I then find that the libjavascriptcoregtk-4.0-18:amd64 is installed again.

I have tried rebooting and also doing sudo apt-get update but no change.

Any repository I try on the next doesn't add so I used the tiliado-repositories_0.4.0-1_all.deb file that installs them.

Any idea's?

2

Nuvola Player developer here. If the installation via the Nuvola Player bundle fails because of conflicts, the recommended method is to use Tiliado Repository Installer.

1

Follow these instructions https://tiliado.eu/nuvolaplayer/repository/ but first run:

  1. sudo dpkg --configure -a
  2. sudo apt-get install --fix-missing
  3. sudo apt-get update
  4. sudo apt-get upgrade -y

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.