0

I upgraded from Freya to Loki recently on my Chromebook (clean install, no crouton etc.). When I try to restart the Chromebook from suspend the display stays dark and needs to be rebooted. On Freya everything worked just fine...

Any advice or suggestions?

Thx

  • I have the same issue when I install proprietary drivers for my external video card. Very annoying. – Константин Тукмаков Sep 14 '16 at 8:32
  • Which Chromebook are you trying to install this on? – Mike Wild Oct 27 '16 at 11:51
1

AFAIK this is about the kernel issues. In some devices (Chromebooks), a newer kernel will solve the problem, but others no. I guess you are using BOOT_STUB or full rom firmware. Changing it to RW_LEGACY firmware may help. Here are some links about this problem:

https://m.reddit.com/r/GalliumOS/comments/4ux2qc/suspend_not_working_on_swanky/

https://github.com/GalliumOS/galliumos-distro/issues/268

  • Hi, I am using legacy boot on my chromebook... – Stefan Sep 27 '16 at 7:54
1

This is a confirmed bug that located here. I have found the best way to deal with this bug without rebooting is to switch your TTY (CTRL-ALT-F1) and run sudo killall lightdm. It should switch you back to the login screen and you should be able to log in and get back to your desktop.

0

Although the fact that it stays completely black in your case might suggest you have another issue, I would still take a look at number six here, which solved my suspend issues:

Problem: Suspend-and-resume generates a stream of errors ...

ehci-pci 0000:00:1d.0: port 1 resume error -19
ehci-pci 0000:00:1d.0: port 2 resume error -19
usb usb3-port1: over-current condition
usb usb3-port1: connect-debounce failed
usb usb3-port2: over-current condition
usb usb3-port2: connect-debounce failed

... and blocks the Chromebook from executing a proper restart/shutdown.

FIX: Create /lib/systemd/system-sleep/ehci-pci.sh ...

#!/bin/bash

case $1/$2 in
    pre/*)
    # Unbind ehci for preventing error
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/unbind
    ;;
    post/*)
    # Bind ehci for preventing error
    echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/ehci-pci/bind
    ;;
esac

... and make it executable ...

$ sudo chmod 755 /lib/systemd/system-sleep/ehci-pci.sh

Configure boot options in /etc/default/grub ...

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash tpm_tis.force=1"

... save the changes and run ...

$ sudo update-grub

Suspend now works reliably when triggered from Ubuntu's shutdown menu or closing the lid and will resume the system with the desktop locked and a password prompt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.