I recently bought this old laptop of Panasonic CF-B10, and installed Elementary OS Freya. Everything works fine except one problem which is driving me crazy: the keyboard and touchpad are frozen after waking up from sleep.

However, if I use a USB mouse and USB keyboard I can still use the laptop, otherwise I would have to hard reboot the system.

I did some googling in the past few days, I have tried:

  1. Reinstalling xserver-xorg-input-all packages;

  2. Adding "atkbd.reset" to "GRUB_CMDLINE_LINUX_DEFAULT=" in /etc/default/grub

  3. Grubbing another SSD drive and installing the latest Ubuntu 16.04;

and maybe something else. None of the above worked.

I have been using this system on multiple laptops and never met this problem before. I am hoping to get some help here. Any suggestion or advice will be greatly appreciated.

  • I'm having the same problem with CF-S10 Panasonic with Ubuntu 16.2 still trying to figure out, If you able to solved this problem, Could you please share it .. I'm sure there is a solution somewhere Thanks – Lona gracia Mar 14 '17 at 13:34

This is likely a Kernel or BIOS problem. The first thing you should do is upgrade to the mainline build. Google how to do that. That is likely not to solve your problem. You should file a bug with the kernel google that too. However, you cannot file a bug (it is very rude and they will tell you soo), without upgrading the BIOS and running the mainline.

Upgrading the BIOS is quite dangerous and you will need to take responsibility for this task and its results. It is especially dangerous without a Windows dual boot. You will need to do this step first, and perhaps it will fix your problem. You will need to google your laptop model number and bios to download the upgraded BIOS. Then you will need to google how to upgrade the BIOS with Ubuntu. If you have Windows, just boot up with windows and double click on the file while the computer is plugged into AC Power, preferably a safe UPS.

If your problem still exists. File a bug. It is not an Elementary problem. You can test this theory with another USB distro if you don't believe me.

I have a simple solution for this issue. Just restart the mouse module ;)

Enter this code in a terminal (Ctrl+Alt+T if you aren't able to click in the icon)

sudo rmmod psmouse ; sudo modprobe psmouse

Cheers!

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.