Yesterday I installed Loki on a an HP 14 Chromebook. Everything is perfect except ...

I can't get Chrome to install in the Elementary environment. I have downloaded the install file from Google and installed the GDebi Package Installer. When I try to run the Chrome install package with either the GDebi installer or Ubuntu Software Center, I get the following error:

Dependency is not satisfiable: libfontconfig1 (>=2.9.0)

I ran an update for this file with the following command: sudo apt-get install libfontconfig1

The command results in the following:

libfontconfig1 is already the newest version. 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 
(precise)asc@localhost:~$ sudo apt-get install libfontconfig 
Reading package lists... Done 
Building dependency tree 
Reading state information... Done 
libfontconfig1 is already the newest version. 
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After running this command, the problem persists. The command results indicate that all is as it should be, but it still doesn't work. Can't figure out what to do next.

I have installed Chromium so am getting along, but would really like to have Chrome installed. Any ideas?

Thanks.

  • Are you sure that you have downloaded the 64 bit google chrome? – lemonslice Jan 3 '17 at 19:59
  • Definitely have 64-bit version. It's the only option that the download page gave me. – AScottC Jan 4 '17 at 21:31
up vote 1 down vote accepted

You might want to install from a terminal with

 sudo dpkg --install ~/Downloads/google-chrome-stable_current_amd64.deb
 sudo apt-get install -f

so that you get more verbose error messages.

Thanks, lemonslice! Excellent suggestion.

It occurs to me (DUH!) that I am not running the latest version of Ubuntu. The latest that crouton supported was ... I think ... Trusty. I'm thinking that this is perhaps the root of the issue?

I'm just digging into the nuts and bolts of Linux so that escaped me. Looks like I have three dependency issues:

google-chrome-stable depends on libfontconfig1 (>= 2.9.0); however:
Version of libfontconfig1 on system is 2.8.0-3ubuntu9.2.
google-chrome-stable depends on libstdc++6 (>= 4.8.0); however:
Version of libstdc++6 on system is 4.6.3-1ubuntu5.
google-chrome-stable depends on lsb-base (>= 4.1); however:
Version of lsb-base on system is 4.0-0ubuntu20.3.

I ran sudo apt-get upgrade on all of those, but it didn't result in anything.

I am assuming that I need to somehow force an upgrade of those three files but have no idea how (or if that's even the right course).

Full error message here:

(precise)asc@localhost:~$ sudo dpkg --install ~/Downloads/installs/google-chrome-stable_current_amd64.deb
(Reading database ... 115476 files and directories currently installed.)
Preparing to replace google-chrome-stable 55.0.2883.87-1 (using .../google-chrome-stable_current_amd64.deb) ...
Unpacking replacement google-chrome-stable ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
google-chrome-stable depends on libfontconfig1 (>= 2.9.0); however:
Version of libfontconfig1 on system is 2.8.0-3ubuntu9.2.
google-chrome-stable depends on libstdc++6 (>= 4.8.0); however:
Version of libstdc++6 on system is 4.6.3-1ubuntu5.
google-chrome-stable depends on lsb-base (>= 4.1); however:
Version of lsb-base on system is 4.0-0ubuntu20.3.
dpkg: error processing google-chrome-stable (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:

google-chrome-stable

FWIW, apt-get check returns this:

google-chrome-stable : 
Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.2 is installed
Depends: libstdc++6 (>= 4.8.0) but 4.6.3-1ubuntu5 is installed
Depends: lsb-base (>= 4.1) but 4.0-0ubuntu20.3 is installed
  • FWIW, apt-get check returns this: google-chrome-stable : / Depends: libfontconfig1 (>= 2.9.0) but 2.8.0-3ubuntu9.2 is installed / Depends: libstdc++6 (>= 4.8.0) but 4.6.3-1ubuntu5 is installed / Depends: lsb-base (>= 4.1) but 4.0-0ubuntu20.3 is installed – AScottC Jan 4 '17 at 22:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.