1

I have searched high and low for some direction in regards to issues I'm having with a recent install of Loki on an HP laptop with suspending the OS.

I have an HP Pavilion with an i5-8250 CPU, 250GB SSD, 8GB RAM, Integrated Intel Graphics and running kernel 4.13.0-32. There is no touch screen nor do I have a second monitor attached. The only attached device is a wireless USB mouse.

The issue(s) I'm having is trying to suspend the OS. If I close the lid or uses the Suspend option on the Power Applet, the machine will suspend then wake up within about 3 seconds. While suspending from the opion on the Power Applet the lock screen appears after the 3 seconds. I can log in and my DE seems to be stable and in the state I left it before the suspend attempt.

Now, I am able to log completely out of the DE then use the Suspend option from the Power Applet and all works just fine. I've never seen this behavior before.

Applications that run full-time on my DE include MEGA-Sync, Insync (GDrive Sync) a weather indicator and Redshift to adjust monitor color. My initial thought was that one of these utilities could be the culprit but even after shutting them down, the issue prevails.

Lastly, in the power options within the Setting Manager, all appears to be set correctly. Also, I have my machine set to auto-suspend after one hour of inactivity and that appears to work flawlessly.

Is there something I added to the DE that is causing this or is it a hardware issue? Thanks in advance for any help!!!

EDIT: I have found that by unplugging my USB mouse that the above issue is resolved. I can suspend the machine via the power applet on Wingpanel as well as shutting the lid. At this point I'm lead to believe this to be a kernel issue or a config issue. Again, any help in resolving this would be appreciated!! Thanks!!!

0

After looking through a multitude of posts elsewhere I was able to solve this issue. Here is what I did:

  1. In Terminal I typed cat /proc/acpi/wakeup to identify the device that was enabled for wake-up. In my case, it is named 'XHC'.

  2. In Terminal I then opened /etc/rc.local with admin privileges by typing sudo scratch-text-editor /etc/rc.local and provided my password.

  3. In the text editor, I added a line above exit 0 that reads echo XHC > /proc/acpi/wakeup then closed/saved the file.

I restarted my machine then tried both the Suspend option in the Power menu as well as closing the lid and in both cases the machine stays suspended as it should. With the lid open while suspended a key hit wakes it and closing the lid to suspend the machine is woke-up by opening the lid.

All is good!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.