1

This is the information I get when I try sudo apt-get update or when I try to use the Package Manager.

Reading package lists... Error!
W: GPG error: http://us.archive.ubuntu.com trusty Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_trusty_main_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

I tried following one of the answers I found here by doing:

sudo add-apt-repository --remove ppa:versable/elementary-update
sudo apt-get clean
sudo apt-get update

but it did not help me. Any help is appreciated!

0

You got two errors trying to update.

First of all, an error with a bad signature. All repositories in Ubuntu are signed with a GPG key, to check its authenticity. Look at the key 40976EAF437D05B5 near the expression BADSIG. You must download the correct signature from the keyserver with this command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5

To solve the problem with MergeList, make a copy of your apt-lists. From terminal, try:

sudo mkdir /var/lib/apt/lists_old
sudo mv /var/lib/apt/lists/ /var/lib/apt/lists_old

Now, remove the wrong lists:

sudo rm /var/lib/apt/lists/* -vf

and finally, recreate the apt-lists with:

sudo apt-get clean
sudo apt-get update 
| improve this answer | |
  • Glad to read it. You're welcome – bitseater Mar 2 '16 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.