I am using freya. When I run sudo apt-get update I got the following errors

W: Failed to fetch http://archive.canonical.com/dists/freya/partner/binary-amd64/Packages  404  Not Found [IP: 80]
W: Failed to fetch http://archive.canonical.com/dists/freya/partner/binary-i386/Packages  404  Not Found [IP: 80]
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty/main/binary-i386/Packages  Hash Sum mismatch
W: Failed to fetch http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/versable/elementary-update/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Total error


2 Answers 2


With reference to your other post, you have followed this AU post.

To solve the error open terminal and run:

sudo add-apt-repository --remove "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo add-apt-repository --remove ppa:versable/elementary-update

For hash sum mismatch run:

sudo rm -rf /var/lib/apt/lists/*

Now run:

sudo apt-get update
  • 1
    @ericb1925 , Would you accept this answer as it works for you, see elementaryos.stackexchange.com/help/someone-answers . You have power to up vote too :).
    – user.dz
    Jan 1, 2016 at 20:42
  • 1
    It worked! In the end I could install the latest version of Nodejs!
    – efkan
    Nov 25, 2016 at 19:37
  • 1
    I just followed this post.. I hope this works and is proper to do in loki Feb 1, 2017 at 0:23

I don't know if someone still has this problem. Anyway, I solved my problem updating those files:

  • appcenter.list
  • elementary.list
  • patches.list

All files are in /etc/apt/source.list.d

And follow instructions from this URL https://bugs.launchpad.net/elementaryos/+bug/1629646

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.