0

E: Unable to correct problems, you have held broken packages

this happens with all packages that have dependencies. My system is blocked. I can't install anything. Doesn't matter which package. sudo apt-get update goes perfect no errors whatsoever.

I tried most solutions offered in forums.

sudo apt-get clean && sudo apt-get update, sudo apt-get update && sudo apt-get upgrade, Sudo apt-get -f install, sudo apt-get -f remove, sudo apt-get --fix-broken install, sudo apt-get clean, sudo apt-get autoclean, sudo apt-get autoremove,sudo dpkg --configure -a, sudo apt-get update,

etc... etc.... etc....

tried to bypass it by "aptitude" and a lot more

I checked hold packages, tried synaptic.edit=> fix broken packages.

Synaptic can't find anything broken. Also apt-get update ends clean.?? But every attempt to install a package with apt-get install or aptitude, where a dependency is needed, i get "...is needed but it is not going to be installed" and "Unable to correct problems, you have held broken packages."

If synaptic doesn't find anything and ap-get update runs ok, Where is that broken package? This silly thing,blocks all possibility to install anything. Even when I remove an installed package and remove the dependencies, and try to reinstall it again, i get the error.

I was happy with my installation. I don't want to reinstall the os. Help.

lemonslice, Thanks for your response. I tried to add it in the text field but it became a mess. I created a txt file. Find the info you requested here in this linked file:

link to file

  • Can you please include a list of your held packages, PPAs, /etc/apt/sources.list file ? – lemonslice Dec 1 '16 at 6:38
  • I added the info in a linked file. – leeuwtje Dec 1 '16 at 13:37
  • What does sudo apt dist-upgrade say ? – lemonslice Dec 2 '16 at 7:14
  • $ sudo apt dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade. – leeuwtje Dec 2 '16 at 10:33
  • 1
    I think I solved my problem. a matter of not checking what's obvious....here is a picture of software&updates and the default settings: askubuntu.com/questions/680965/software-updates-defaults – leeuwtje Dec 5 '16 at 14:03
1

I think I solved my problem. a matter of not checking what's obvious....here is a picture of software&updates and the default settings:

https://askubuntu.com/questions/680965/software-updates-defaults
For some reason the 2 upper settings; canonical en community were off....After switching them on and do a sudo apt-get update && sudo apt-get upgrade -y, the problem was solved. I can install packages again. I noticed the problem when I started trying installing dependencies manually, till I found that the dependencies gave a "no installation candidate:" error. Than I checked the software&update settings...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.