3

A "Failed to update “Operating System Updates”" message is displayed in a pop up and, if I click "Details", it shows the following:

The following packages have unmet dependencies:
  linux-modules-nvidia-470-5.11.0-40-generic: Depends: nvidia-kernel-common-470 (<= 470.82.00-1) but 470.86-0ubuntu0.20.04.1 is to be installed

If I run sudo apt-get update and then sudo apt-get upgrade it shows the same message as above. If there is a fix in the works let me know and, if I can fix it myself, I am willing to do so if its not too complicated.

2 Answers 2

2

You may be able to resolve this by re-installing the common libraries for the Nvidia driver.

From a Terminal, run this command to re-install the common libraries:

sudo apt --reinstall install libnvidia-common-470

Then ensure you have the proper hardware drivers installed:

sudo ubuntu-drivers autoinstall
4
  • also how do i close this thread
    – kewal gill
    Dec 1, 2021 at 2:56
  • Glad that you could resolve your issue. This site is a Q&A site, so doesn't work like a forum where threads are open or closed. The best option would be to write an answer, explaining what you did with a step-by-step for other people, then mark that as the accepted answer 👍🏻
    – matigo
    Dec 1, 2021 at 3:32
  • ok, i'll delete my comment and paste it as an answer. stay safe, have fun and thanks for the directions.
    – kewal gill
    Dec 1, 2021 at 3:41
  • 2
    I had to run sudo apt --reinstall install nvidia-kernel-common-470, which installed 233Mb of packages solving my issue!
    – ZedTuX
    Dec 1, 2021 at 7:16
1

So to solve my issue, i removed the nvidia 470 driver through app center by the following way: open appcenter->clicking the installed tab->then by selecting nvidia-driver-470-> click uninstall-> reboot system. then after reboot: open appcenter->go to installed tab->wait for the updates to show up->update all->open terminal->paste this command (without quotes) "sudo ubuntu-drivers autoinstall"->when this command is finished rebooted my system. now my system is running normally, i even got some new update that got installed without any issues. so it seems like the problem is solved.

matigo gave an answer which i used to solve the installation of the driver through command line. sadly due to me not having enough reputation, i cant upvote his answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.