Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [dependencies]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
2 answers
140 views

Operating System Updates fail in AppCenter. Runs for 1 second, stops, and the updates are still pending. (grub related packages held back.)

sudo apt upgrade results in: "The following packages have been kept back: grub-common grub-pc grub-pc-bin grub2-common shim shim-signed": michael@elementaryOS-phy:/$ sudo apt upgrade Reading ...
Michael Rhodes's user avatar
0 votes
1 answer
385 views

Installing missing dependencies

So one of the first things I tried to do with my fresh install of Elementary OS turned out to be a noob mistake. I followed a youtube tutorial to install Elementary Tweaks only to learn that it's not ...
KMLNwalkabout's user avatar
3 votes
2 answers
395 views

Elementary os 6 Odin not updating due to unmet dependency

A "Failed to update “Operating System Updates”" message is displayed in a pop up and, if I click "Details", it shows the following: The following packages have unmet dependencies: ...
kewal gill's user avatar
0 votes
1 answer
155 views

How can I fix unmet dependencies update error

How can I fix unmet dependencies update error? The following packages have unmet dependencies: linux-modules-nvidia-470-5.11.0-38-generic: Depends: nvidia-kernel-common-470 (<= 470.74-1) but 470....
zensir's user avatar
  • 23
1 vote
1 answer
2k views

Cannot run Steam; missing libc.so.6

Like the title says, I have problems starting Steam. Dishes out error; You are missing the following 32-bit libraries, and Steam may not run: libc.so.6 Intel i5-6600k , 64-bit system, 16GB Ram, Nvidia ...
JonSchiz's user avatar
0 votes
0 answers
76 views

Wine packages are held back

I have some Wine packages held back when updating Listing... Done wine-stable/bionic 5.0.3~bionic amd64 [upgradable from: 4.0.3~bionic] wine-stable-amd64/bionic 5.0.3~bionic amd64 [upgradable from: 4....
Michael wx's user avatar
0 votes
1 answer
696 views

I cannot install WINE

Whenever I try sudo apt-get install wine-stable I get The following packages have unmet dependencies: wine-stable : Depends: wine-stable-i386 (= 5.0.1~focal) Depends: wine-stable-amd64 (= 5.0.1~focal) ...
Joshua Ham's user avatar
-1 votes
2 answers
2k views

Problemas con mis Graficos nvidia

De antemano Saludos a quien pueda leer esto. Estoy presentando un problema grave con mi elementary, mi laptop es una toshiba satellite p-50-a-12z i7-4700 con una grafica nvidia GK107m Geforce GT 745M....
Diego Perozo's user avatar
0 votes
2 answers
323 views

switchboard-plug-gcc-sound - "unmet dependencies"

Sorry to bring this up after ~3 years, but I'm stuck on the suggested solution: I have a similar issue, but when I'm running this: sudo apt install switchboard-plug-gcc-sound I get this: The ...
Lopofsky's user avatar
  • 103
0 votes
0 answers
100 views

Installed Libreoffice by adding the Libreoffice PPA - now system is broken

I installed Libreoffice via PPA (ppa:libreoffice/ppa) and all installed fine. Running "apt upgrade" afterwards, everything was fine. Then after a recent update something seems to have broken and I ...
Mark's user avatar
  • 1
0 votes
1 answer
123 views

tried very hard to install wine but it always shows this

The following packages have unmet dependencies: wine-stable : Depends: wine-stable-i386 (= 5.0.0~eoan) Depends: wine-stable-amd64 (= 5.0.0~eoan) but it is not going to be installed E: ...
shahnawaz's user avatar
1 vote
1 answer
464 views

How to install dependencies?

I am new to elementary OS and want to install Akira UX. But I have no idea how to install the dependencies mentioned there. Can any of you guys have command to install the dependencies?
Yash's user avatar
  • 11
0 votes
3 answers
113 views

File manager deleted after update, now can't reinstall it (broken dependencies)

After a recent update and apt autoremove, the Elementary OS files app was somehow removed. I tried to reinstall it from the appstore, only for it to complain that tumbler and tumbler extras needed ...
adamdesign's user avatar
2 votes
1 answer
139 views

Can't install/remove, upgrade/update ANYTHING

I use OpenOffice, but got curious why so many Linux users and distributions are more into LibreOffice, so I downloaded it to check it out. When I tried to install it (a while back) I got an error ...
Joy's user avatar
  • 85
0 votes
1 answer
503 views

HPLIP 3.18.4 upgrade

I'm trying to get the latest HPLIP 3.18.4 installed for a new printer that I purchased. My printer requires HPLIP 3.16.11 or greater and Elementary OS only provides 3.16.3 at this time. Going through ...
Andrew's user avatar
  • 13
0 votes
1 answer
456 views

Unable to update or install anything due to unmet dependencies [duplicate]

Originally, I was just having trouble installing updates, but in my attempts to fix that, it would seem I am unable to install anything at all. Anytime I try to install something, I get the same list ...
Curtis Balz's user avatar
1 vote
1 answer
537 views

(libcups2) dependency hell after apt upgrade

Some broken packages have been shipped in mainline. Package libcups2 has broken apt completely after an upgrade. When I try apt -f install the package manager suggests to remove a whole batch of ...
roy's user avatar
  • 21
1 vote
2 answers
371 views

Loki Broken dependencies. Not sure how to fix (Sudo apt-get install -f won't help)

So i tried installing DiscordApp and it tells me i got broken dependencies and that i need to run "Sudo apt-get install -f" However doing that yields this error: Errors were encountered while ...
Empa's user avatar
  • 13
0 votes
0 answers
908 views

Install libgtk2.0-0:i386 dependency problems [duplicate]

I'm trying to install libgtk2.0-0:i386 to solve this error: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory However, when I try ...
Timothy Gray's user avatar
2 votes
1 answer
3k views

Gnome software centre is not installing

I'm trying to install the gnome software centre but its is giving me this error in terminal sudo apt-get install gnome-software Reading package lists... Done Building dependency tree Reading ...
Alan Jameson's user avatar
0 votes
1 answer
557 views

Why do I get these errors?

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/elementary-os-ubuntu-os-patches-xenial.list:1 and /etc/apt/sources.list.d/patches.list:1 W: ...
RcL's user avatar
  • 11
0 votes
2 answers
1k views

Loki - running on a Chromebook using crouton

Yesterday I installed Loki on a an HP 14 Chromebook. Everything is perfect except ... I can't get Chrome to install in the Elementary environment. I have downloaded the install file from Google and ...
AScottC's user avatar
8 votes
2 answers
4k views

Using Redshift on Elementary OS

I installed Redshift 1.11 on Elementary OS Freya but I noticed that the methods list only mentioned the dummy method (which just displays the target gamma in the terminal). $ redshift -m list ...
Peter Uithoven's user avatar
0 votes
1 answer
234 views

Git instalattion, unmet or you have held broken packages [closed]

Loki Beta running smoothly. Unable to install Git- Tried with numerous methods no Luck. I receive The following packages have unmet dependencies: git : Depends: liberror-perl but it is not ...
mystified's user avatar
0 votes
2 answers
4k views

Problems with broken packages

I'm trying to install musescore but this error comes ahead: I tried sudo apt-get install -f but nothing happens. Any ideas?
jacosro's user avatar
  • 790
1 vote
3 answers
586 views

Trouble with APT, DPKG, SYNAPTIC. Linux-Image-thing

Having some errors after trying to upgrade with apt-get/synaptic. There are several error messages in the output, like: P: Installing debian theme...cp: cannot stat ‘/usr/share/syslinux/themes/debian-...
neb's user avatar
  • 21
2 votes
1 answer
298 views

Missing index files from elementary repo

After doing a package update I get a 404 error when it's trying to fetch http://ppa.launchpad.net/elementary-os/os-patches/ubuntu/dists/freya/main/binary-i386/Packages How can I solve that missing ...
Maccer's user avatar
  • 1,984
6 votes
1 answer
602 views

Skype - can't install it on Freya

I am using elementary OS Freya. I was unable to install Skype. I've formatted my laptop and installed Freya (twice), same thing. Can't install Skype, same error: luffy@luffy-Satellite-C850-B797:~$ ...
ericb 1925's user avatar
0 votes
2 answers
684 views

Unable to install vlc

When I ran: sudo apt-get install vlc- I got: ravan@ravan:~$ sudo apt-get install vlc Reading package lists... Done Building dependency tree Reading state information... Done Some packages ...
Ravan's user avatar
  • 7,877
1 vote
0 answers
584 views

Elementary OS Freya stuck on desktop image after boot

I had a bunch of held packages and attempted to fix it using Aptitude as suggested here. It mentioned removing a bunch of packages, but I accepted that after seeing a few of the packages being updated ...
SpydaMonky's user avatar
3 votes
1 answer
875 views

Unable to install skype on elementary OS

I am using elementary os freya. I followed this post to install skype. ravan@ravan:~$ sudo apt-get install skype Reading package lists... Done Building dependency tree Reading state ...
Ravan's user avatar
  • 7,877