How can I fix unmet dependencies update error?

The following packages have unmet dependencies:

linux-modules-nvidia-470-5.11.0-38-generic: Depends: nvidia-kernel-common-470 (<= 470.74-1) but 470.82.00-0ubuntu0.20.04.1 is to be installed

1 Answer 1


You can try the solution that has worked for me (I have posted the same issue just before you):

Failed update-what to do about it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.