2

The only thing that has been bugging me with ElementaryOS is the Terminal. Attempting to type into the Terminal works just fine, but when I try and use Vim or a REPL and the output spans multiple lines, the editing of the text in that Terminal slows to a crawl.

In addition, attempting to remove characters will end up causing the cursor to appear one place to the right than it actually is, which means pressing backspace when the cursor is over a white space will actually delete the letter next to the whitespace.

I don't have this issue with gnome-terminal or xterm; it's only the Pantheon Terminal that appears to have this issue.

It makes editing with vim a pain, and for some reason I can't snap gnome-terminal to the dock either.

  • Probably best to post this over on the bug tracker. – elmato Nov 10 '15 at 0:40
  • @elmato bug tracker seems to indicate it might be an issue with my nvidia card. I'll attempt the fix displayed in the bug tracker (for some values of "fix") and see if that resolves it once I get home tonight. – Dan Pantry Nov 10 '15 at 10:30
2

After looking at the bug tracker linked by @elmato, I found an issue about vim being slow.. following the settings described in this comment fixed this issue for me. Relevant excerpt below:

I also mentioned a bug about this. I have found a solution (maybe not the best, but it works).

This only works if you have nvidia drivers installed. Open the nvidia settings, and under PowerMizer, change to maximum performance.

I guess the terminal uses the GPU a ton to render, and when it's lowering clock speeds to save power, it's reducing performance of the terminal.

(from i-r-stuff)

Not the answer you're looking for? Browse other questions tagged or ask your own question.