With 0.3.2 Freya on a i7-3537U CPU @ 2.00GHz, and a NVIDIA Corporation GK107M [GeForce GT 740M] (rev a1) (an Asus laptop), my experience was allways having glicthes when I change windows.

Sadly, I tried this: https://www.reddit.com/r/elementaryos/comments/33nbod/if_you_are_having_cursor_issues_andor_visual/ Which nearly broke my system (or so I thought). It got me into a login loop. And I had to boot from a USB disk and undo it.

So, back to the glitches. Which are anoying when I am watching movies, or comics, or just changing windows, scrolling - basically all the normal stuff you do in your computer.

Someone said that with Freya 0.3.1 a wonderful new world would come and all this would be solved and also that this happened with old systems. Graphics issues on elementary OS Freya Atom N550 (GMA3150)

Is an i7 and a GeForce GT 740M old? Is suddenly a linux system supposed to work only if you have the newest hardware available?

Severall users are having this issue. The reddit users seemed to be the only ones that said (with hurrays and flowers) it worked... thank you so much. So sorry to spoil the party, it did not work for me. And I did not feel like creating a reditt account just to spoil their little party.

So sorry for my bitterness today.

Elementary is my favorite OS. it is :D And I will defend it with passion. Nearly broke my PC (took me 3 days to install it - and to get over the grub loop). Now my battery ends a lot quicker than with Windows 8 or 10. My almost brand new Epson printer does not work. Every time my other machine (a PC) is working with the printer, my Elementary OS says proudly "No drivers for your printer" and I love him for that.

I do.

But these glitches are too much. Like always: if there is a solution, I'll take it. If there is not, I'll take it as it is.

Life does not suck, with Linux.

Thank you for your time. (With Ubuntu, that I now dislike because of their conections with Amazon and the chinese defense ministry, most of the time I just waited - impatiently - and things got solved in future updates).

Please make this future update in the near future. Hope this is bugging someone who knows code, or is involved in the development of the OS. That would gets things done.

[obviously, I understand that Elementary 1.0 was not released yet. And I am proud to be a supporter at this stage. What I like about the Linux community is this willingness to make amazing software that is truly ours, the user's. So, I do take responsability for it, for the decisions I make, for the effort I put in it. Even if I don't know the first thing about code. I know this is mine, and I cherish the people who made the code, in a transparent way, so that I can trust nothing funny is under the hood. Thank you for that.]

2 Answers 2


The solution you tried is for Intel displays, hence "Driver 'Intel'", you have Nvidia. Your login loop was a result of forcing X-windows to run the Intel driver.

Have you tried installing the proprietary Nvidia drivers. You can install them by running " Software Updater " from the applications menu, after it has checked for updates click the "settings" button, click the "Additional Drivers" tab.

After you have enabled the Nvidia driver then you can install nvidia-settings from the software centre that will add an application for controlling different aspects of your graphics card.

  • Yes, I do have the Nvidia X Server driver installed, since Elementary OS was first installed. IT is updated, now on v331.20 version. Thanks for trying to help, Dave G. The glitching continues and now I associate it with using two monitors. Or, at least, it's worse, with two monitors. It goes away when I click on "the other" monitor once, whatever monitor the glitch showed up in. It is now part of my user habits. But it feels a shame to have such a nice looking OS and have to keep clicking the glitches away. It looks like a broken system.
    – hainish
    Jul 15, 2016 at 15:43

I'm think you can fix it, It seems that the solution is in the #5 comment also I had the same problem the first time that I installed elementary OS freya and it worked for me. Screen flickering

  • Thank you for the suggestion. That was the reddit solution I tried and it got me into a log in loop. It not only did not work for me, but force me to use a flash disk boot to correct it.
    – hainish
    Mar 16, 2016 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.