2

Kswapd keeps choking up my laptop. It's a new Dell ultrabook with 8GB RAM.

This old bug report has the best description of the bug:

Any time I have a process that is both using 100% CPU and eats up memory, the system becomes unusable as soon as it starts using swap. At this point the hard drive starts thrashing and X slows to a crawl (the pointer updates maybe every 30 seconds). My only options at this point are to 1) hope the program finishes and gives some memory back, 2) wait for swap to fill completely so the kernel will kill the program, or 3) reboot the computer. The latter option is usually 5-10 minutes faster.

In my experience, this only happens with elementaryOS. I ran stock Ubuntu 14.04, 14.10 and 15.04 with innumerable heavy processes and never ran into this issue with kswapd. Last time I installed elementary, it was on an Acer Chromebook and the exact same issue arose after running too many processes at once (to be spec., usually more than 6 browser tabs in Chrome, Wine Photoshop, JetBrains IDE, maybe FF or another browser open as well).

I've tried messing around with swappiness as suggested in this SO.

I also reformatted the swap partition and re-made it (moving partitions around, I think, may have caused some problem there, because I noticed an improvement).

  • How much memory do you have on your system, and as well, how much space does SWAP have available? – Zzzach... Jan 31 '16 at 19:56
  • 8GB, w an 8GB swap – RoboRob Feb 2 '16 at 20:23
1

For posterity, I experienced this issue until I installed zRam, and since then I've had basically unlimited memory capacity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.