0

Everytime I close my terminal after running plank & the dock disappears. I also get this warning

[WARN 20:23:03.825433] [Environment:165] XDG_SESSION_CLASS not set in this environment!
[WARN 20:23:03.853953] [Preferences:192] '/usr/share/plank/themes/Default/dock.theme' is read-only

Could someone please help? Thanks!

1

This would be expected behaviour, the & whilst making it a background task does still keep it as a child process of the terminal so when the terminal is closed so does plank. If you wish to keep it alive this question may be helpful: https://unix.stackexchange.com/questions/4004/how-can-i-run-a-command-which-will-survive-terminal-close#4006.

| improve this answer | |
0

By default plank is into the cerbere applications list so if you did not removed it from there, it should launch again after you kill it. I do not know why you running plank from terminal, but if you just want to restart it use killall plank instead if it is still in the cerbere list.

If you are doing this in order to change the theme, the location of the warning message is read only so if you want to add a custom plank theme it is better to put it in ~/.local/share/plank/themes/ folder. You can go into this location if you enable hidden files for your files application and navigate from home folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.