9

When I open qBittorrent or calibre they show for a moment in the dock and then go away. I am using qBittorrent v3.3.1 which is in the official repository and calibre v2.70 which I downloaded from calibre website.

I searched around and found two questions relevant to my problem. This question is similar but the solution does not work for me. I already had the Show Unpinned option ticked.

This question deals with multiple icons of same application.

I found a workaround for qBittorrent. There is a qBittorrent icon at the top when it is running. Clicking on this icon brings up a menu with a option Hide. Clicking Hide twice in this menu brings back qBittorrent icon in plank.

UPDATE:

The list of softwares seems to be growing. Now mousepad and virtualbox also do not show up in the dock.

  • Does this happen if you try to run these applications from a guest account as well? – lemonslice Dec 6 '16 at 22:38
  • I tested with various softwares. Only Codeblocks and Texmaker seems to have this problem in guest account. – Ibraheem Moosa Dec 7 '16 at 1:07
  • There has been a plank update yesterday (to 0.11.3), in my installation this bug does not happen any more. Can you check it for yours? – lemonslice Dec 8 '16 at 19:58
  • No that does not solve the problem in my computer. – Ibraheem Moosa Dec 10 '16 at 12:59
  • same issue here, did anyone solve this issue? – Tsulatsi Tamim Apr 7 '17 at 3:08
2

Same issue. Currently I go to dock preference (ctrl + Right Click), comportment, and I disable/enable Show unpinned. But it's not a solution of course.

It's boring but it's work (or Alt+Tab)

  • no problem. it's not realy an answer but just for wait a fix or something better. – Shining Dec 10 '16 at 12:15
1

For Calibre go to preferences/ look and feel and enable tray icon. That makes it stay in plank too.

I haven't tried this for other apps.

  • This is a possible workaround, a real solution would be nicer to have... – Rafael Dec 6 '16 at 15:42
0

the simplest solution to me currently is to make plank strict between workspace and switch the workspace ,on ubuntu, or linux mint: ctrl+alt+(or). it refreshes the plank.

-2

@Ibraheem Moosa The solution is quite simple. The only thing you have to do is edit the file /usr/share/applications/calibre-gui.desktop with root rights and change the line:

Exec=calibre --detach %F

To

Exec=calibre

  • It doesn't work. – Rafael Dec 6 '16 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.