0

I made a .desktop file so I could run an .sh file from the Plank dock. It is as follows:

[Desktop Entry]
Type=Application
Terminal=true
Name=Drive
Icon=/home/finn/Programs/drive-logo.png
Exec=/home/finn/Programs/grive.sh

It links to this .sh script, which is currently a placeholder:

#!/bin/bash
cd ~/Drive
mkdir itworked

The last line will be replaced with grive once I get it working. At the moment it just makes a folder so I can see if the script ran successfully. I made it executable with sudo chmod +x drive.desktop while in /usr/share/applications. Currently it works perfectly if I navigate to /usr/share/applications in the Files browser and double-click on the icon. It shows up in the Slingshot applications menu, and I can drag it to the Plank dock, but when I try click and open it from either of these places it does nothing. Weirdly, if I open Files as Administrator and then try open it from there it also does nothing. I've tried setting the permissions to match other applications, or just be fully open to everyone, but it didn't help.

1

I just changed the third line to terminal=false and it works now, which is a shame because I wanted to have the terminal open when the drive syncs, but I guess you can't have everything.

Looks like it's been a bug for a few years, not really eOS's fault: https://bugs.launchpad.net/pantheon-terminal/+bug/1176526 https://bugs.launchpad.net/slingshot/+bug/1066462

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.