A couple of days ago I updated elementary OS through the software updater, and after restarting the laptop, the touchpad no longer worked. The mouse would not move from the center of the screen. First, I verified I did not accidentally turn off the touchpad with the hotkey. I was able to get the touchpad to work by running the following commands:

sudo modprobe -r psmouse
sudo modprobe psmouse

This allowed me to regain control of the mouse, however, two finger scrolling does not work. I went to the touchpad settings and checked the two finger scroll checkbox, but the change is not saved after exiting settings. Once I open the touchpad menu up again, the two finger scroll checkbox is still unchecked. Finally, the commands above are not persistent after a restart.

Any ideas on how to fix this?

4 Answers 4


First we are going to check if the touchpad is really using the settings it should.
Open a terminal and type: xinput
Look for your touchpad and remember the id number. Then type: xinput list-props.
If a setting is set to 0 it means it's unchecked. If you want to set it to 1 just type
xinput set-prop [id] [setting number] 1 .
The same applies if you want to set it to 0. Finally, to make those settings persistent you need to create a .conf file. But to do so I need to know what files you have inside /usr/share/X11/xorg.conf.d

Basically it would be completing this file:

Section "InputClass"
Identifier "touchpad"
Driver "synaptics" #maybe other driver
MatchIsTouchpad "on"
    Option #[option here]

Had exactly the same problem. When You type xinput You can notice, that your touchpad is now recognized as PS2 mouse. Try to reinstall the driver, it should fix this. Just check if you need Elantech/Synaptic/etc driver, remove it with

sudo apt-get remove --purge <your driver package>

And reinstall it with

sudo apt-get install <your driver package>

Hi all i have upgraded my kernel using linux kernel updater from here https://github.com/bkw777/mainline

kernel version in my elementary os is now 5.11, and everything works including my touchpad and display drivers


This might sound silly, but it worked for me until I found an updated driver for my laptop's track pad. But once you boot if your mouse isn't working, try suspending your laptop and resuming.

No guerentees, and I've not a clue why it was working this way, but it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.