2

I'm testing Freya in live mode but on my Asus X555 laptop the touchpad is not recognized.

I've found some tutorial to install Focaltech driver, anyway if I run xinput list from the command line i don't see any Focaltech emulation mode. It just show Virtual Core XTEST Pointer. How can i fix it?

Edit 1: I've just tried with a persistent USB mode. Installed Focaltech drivers and nothing has changed.

Edit 2 This is the output from xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft(R) Compact Optical Mouse  id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 VGA UVC WebCam                     id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]

The command uname -r returns 3.19.0-39-generic And this is the output from lspci

00:00.0 Host bridge: Intel Corporation Device 1904 (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 08)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:15.0 Signal processing controller: Intel Corporation Device 9d60 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Device 9d61 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device 9d14 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Device 9d15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

EDIT 3 I've also tried Ubuntu 15.10 live mode, with this distro the touchpad works as a mouse, no other gestures like 2-finger scrolling. The model name shown by xinput list is ELAN1000:00 04F3:0401

-1

Press and hold FN, press F9. Release FN.

  • I do not have an FN key, and it is likely that this shortcut is not universal. A more descriptive answer would be more helpful. – Lewis Goddard Feb 16 '16 at 20:44
  • I tried this combination and up near the shutdown button for a while show the sign of touchpad with cross what thats mean?? – user4265 Feb 25 '16 at 18:23
  • @Lame It means that the touchpad has been disabled. I assume the user thought that your touchpad was simply turned off. – Lewis Goddard Feb 26 '16 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.