1

I've been using elementary OS on various computers for years. I recently upgraded my travel laptop from a lower end unit (Lenovo N-22, Celeron, 4GB) to something with a bit more capability (Lenovo 11e, i3, 8GB).

Unfortunately, on this unit both elementary and Ubuntu treat the secondary trackpad/mousepad button the same as the primary button. While a two-finger tap does function as the secondary button, it's not the same experience. Oddly, the button works as expected on Zorin, Deepin and Wind*ws, so it's not a hardware issue.

I've read that things can get dicey on trackpads where the buttons are part of the general pad surface. I've installed xserver-xorg-input-synaptics but that has not made any difference.

If anyone has any driver or configuration suggestions then I'm all ears. Any suggestions would be appreciated!

Update 1: I have just re-tried System Settings -> Mouse & Touchpad -> Touchpad -> Physical clicking -> Hardware default

The issue persists.

Update 2: As requested, here is the output of: apt list --installed | grep "xserver-xorg-input-libinput"

xserver-xorg-input-libinput/bionic,now 0.27.1-1 amd64 [installed]

Update 3:

After installing gnome-tweak-tool and the selecting "Area under Mouse Click Emulation" Mouse Click Emulation option there is no change in behavior. Clicking the lower right button area of the trackpad is still treated as if the primary button is pushed. This behavior continued following a system reboot.

  • I have just re-tried System Settings -> Mouse & Touchpad -> Touchpad -> Physical clicking -> Hardware default The issue persists. – Moontan Apr 17 at 10:42
  • Please update your question with the execution result / output of apt list --installed | grep "xserver-xorg-input-libinput". Simply edit your question with what you see after executing this command in terminal. – Hasan Apr 17 at 12:30
  • If you don't see anything after executing the command from my earlier comment, please execute sudo apt install xserver-xorg-input-libinput and let me know if this fix your issue. – Hasan Apr 17 at 12:41
  • Please install sudo apt install gnome-tweak-tool via terminal and go to Keyboard and Mouse sub-menu. After that please select the option Area under Mouse Click Emulation. Please let me know what you find. – Hasan Apr 19 at 4:25
  • I see. Please add how you solved problem as answer instead of editing the question. – Hasan Apr 19 at 20:09
1

In System Settings -> Mouse & Touchpad -> Touchpad tab, make sure that Physical Clicking is switched on and set to Default Hardware.

  • Your contribution is much appreciated, However, please always try to add more information about what to do and why to do. This is will be more helpful understanding the solution and the problem. – Hasan Apr 17 at 7:11
  • a) I don't see how can "add more information about what to do", as long as you have eyes you'll be able to follow. b) I cannot go into technical details on "why" because I don't know them. Should I then refer myself from posting if I know the answer to the problem but not completely understand the technical background? – user511 Apr 17 at 7:33
  • So you're saying that if I don't know the reason behind why "default hardware" will work I should not help at all. Is that correct? – user511 Apr 17 at 7:53
  • I understand your point. But I also mentioned why and I think it will be more helpful for OP why they re following the steps. For example, why "make sure that Physical Clicking is switched on and set to Default Hardware" and why not "touchpad areas" or "multi-touch". Just a matter of making the answer as detailed as possible. No, as a user you are always welcomed to ask questions and answer. Perhaps someone who know will improve the answer. Thats how the network works. Please don't get me wrong. – Hasan Apr 17 at 7:54
  • I know that I'm welcomed, and I know that someone could add clarity to my post, but you're avoiding answering my question - if I don't know the reason behind why "default hardware" will work I should not help at all? – user511 Apr 17 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.