0

My ETPS/2 Elantech Touchpad stopped working after an update. Before a few days it worked fine, but now I can't do anything only the buttons are working. It seems to be the same problem as described here: ETPS/2 Elantech Touchpad. Buttons work, cannot swipe

I tried the solution described there, but installing the focaltech-dkms drivers, modprobe -r psmouse and modprobe psmouse didn't help. I rebooted and checked if touchpad is activated in the system-settings.

Has anyone a clue where to look further or another solution?

xinput gives me the following line:

# xinput
⎜ ↳ ...
⎜ ↳ ETPS/2 Elantech Touchpad id=15 [slave pointer (2)]
,

so it seems to be recognized.


EDIT: I also tried the solution below, but there is no serio4 directory, only serio0 and serio1. Since the change is not permanent apparently, I tried this command (as root, didn't work with sudo):

echo 1 > /sys/devices/platform/i8042/serio1/reg_07
It executes without an error, but the touchpad still doesn't work.

cat /sys/devices/platform/i8042/serio1/reg_07 gives me 0x07 as output. Is this correct? Shouldn't be there a 1 or at least a change?


EDIT.EDIT: When the screen turns black due power saving options, it gets back to life when I touch the touchpad, but the mouse pointer is still not moving.

1

Oh my gosh, I totally forgot that I had to install the xorg-dev package for testing purposes. It seems that the xserver-xorg-input-mtrack package was removed with this process.
After re-install xserver-xorg-input-mtrack and rebooting the notebook everything is back to normal!
Thanks @dave-g for your help. I would say a win-win: touchpad is working again and I have updated my kernel =)


EDIT: To clarify: Updating the kernel didn't help, but without the correct xorg-driver it never could.


EDIT.EDIT: 'Cause the xserver-xorg-input-mtrack didn't work well (two finger swipe let the pointer jump around) I had to install xserver-xorg-input-synaptics and reboot to have the best touchpad (or trackpad?? Seriously I'm confused..) experience.

0

There is a known bug regarding the ETPS/2 touchpad, try the following in a terminal:

sudo su -
echo 1 > /sys/devices/platform/i8042/serio4/reg_07

If it works it will only work til you reboot so you will need to add the line:

echo 1 > /sys/devices/platform/i8042/serio4/reg_07

to /etc/rc.local just before 'exit 0' to make it run that command at boot.

Edit....

If serio4 doesn't exist you can find out which one it should be with

cat /proc/bus/input/devices | grep -iA 9 touch

  • Sry, forgot to mention that I tried that also. I'll edit my question.. – ZaphBBrox Jul 14 '16 at 15:55
  • Can you plug a mouse in and use it, if so it confirms it is an issue with the touchpad, if the mouse doesn't work then it could be an issue with x-windows or part of the desktop environment. If its just the track pad you could try updating to the latest kernel as the bug I mentioned is in the older kernel. You can do that by opening a terminal and typing: sudo apt-get install linux-image-generic-lts-xenial . You will have to reboot for it to take effect. – Dave G. Jul 14 '16 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.