0

I have two 1 TB hard disk and I am planning to install elementary OS 15.1 on my system. I am planning to keep both hard disks on software RAID1. I am planning to keep a separate partition for

  • /
  • /boot
  • /home
  • swap

When I tried on my VMWare setup, I can install an elementary OS, when I am not creating separate above partitions. When I tried splitting into multiple partitions, the installation gets stuck in grub installation failure and shows multiple options to proceed.

  1. Selection of different partition where grub will be installed.
  2. Install bootloader later.
  3. Cancel installation.

I am not able to select any options, the "okay" button is not responding. Is there any guide on how this can be resolved?

0

Unless you have a hardware RAID controller, you will need to use a software RAID controller/volume manager.

Typically, mdadm is used to create mdX devices which can be overlaid with your filesystem of choice. For UEFI, you will need a /boot/efi partition as usual, as well as a /boot partition of type Ext4 to provide the physical partition for which the mdX device containing your RAID volume will be.

You can currently apply similar methods mentioned here for your installation of elementary OS. Once your mdX devices are created, start/probe them from the elementary OS live session and then select those as your root point.

|improve this answer|||||
  • Well, I did tried it out with creating mdx device before installation (live cd), I am able to install elementary os if I am not making separate partition and creating only / partition. Problem comes when I create multiple partition from single mdx. – Rakesh.N Dec 15 '19 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.