0

I have a HP EliteBook Folio 1040 g with a 128GB SSD that used to have Windows. I have successfully replaced it with Zorin OS. Then I thought I'd like to try Elementary OS. However, when I try to install Elementary OS the installer doesn't seem to recognise my hard drive?

First Scenario

If I choose "erase disk and install" it fails. On the details screen I see the following error:

partitioning error: disk commit error: failed to commit libparted changes to "/dev/sda": No such file or directory (os error 2)

Second Scenario

If I start with "custom Install" I see no coloured partitions in the partition selector screen. When I run gparted I start seeing messages like:

Input/output error during write on /dev/sda

and

The backup GPT table is corrupt, but the primary appears OK, so that will be used

I'm able to create my partitions, but when I click apply I see the above 2 messages multiple times. After the operations are complete and I close gparted and go back to the installer, then I still see no coloured bars in the partition selector.

Interlude with gdisk

At this point in time, I ran gdisk to find out more info:

sudo gdisk /dev/sda

Initially it tells me that MBR is "protective" and that GPT is "damaged". If I choose the "v" option, it tells me that the CRC for the backup partition table is invalid. Using the main partition table to restore the backup doesn't seem to make a difference. The last option I chose was to "convert GPT into MBR and exit"

Scenario Three

If I start with Custom Install and an msdos partition table, I am able to run gparted without error and create my partitions. Back on the selection screen I am able to nominate a boot/EFI partition (fat32), a linux-swap partition and an ext4 partition. However, the install fails. If I look at the Details section, it says:

Install error: partition validation: EFI installs cannot be done on disks without a GPT partition layout

Extra Info

After searching around I found references to a couple of things that might prevent the install:

  1. I made sure that the drive isn't setup as RAID
  2. Secure Boot (in my BIOS) is set to "Legacy Support Enable and Secure Boot Disable"
  3. I did try to boot in legacy mode, but UEFI is the only option for my USB key

I'm a little out of my depth here. I don't quite understand why I'm able to install Zorin OS (and I've successfully installed Linux Mint) and I can't install Elementary OS?

1 Answer 1

0

You could try to run gparted from a Live System CD or USB stick and clear all partitions so that all of your former installations are fully deleted. If an error occurs, your harddisk might be at its end of life. Otherwise install Elementary OS again.

[edit] I‘m not sure if this helps, but gdisk /dev/sdb on my PC returns: MBR protective,BSD not present, APM not present, GPT present, Found valid GPT with protective MBR; using GPT. sdb is my system drive. Gparted has this device info: Model:…SSD, S/N:…,465.76 GB, Path/dev/sdb, Partition table: GPT,… The box on the right says: Partition File system mount point Size Used Unused not allocated not allocated - 2.00MB—- —- /dev/sdb1 fat32 /boot/efi 263 MiB 11 MiB 251MiB /dev/sdb2 lvm2 pv data 465GiB 465GiB. 0.00B not allocated not allocated - 2.00MB

This is how my system is set up. By the way, sda is another ssd which had ElementaryOS5 cloned from another computer on it. It booted immediately in the new PC and was allocated sda. Gparted failed to remove its partitions, so I used Windows and DISKPART.

Hope this helps.

3
  • Thankyou! But I have already tried this and the above is still true. That is, if I use GPT I get the above errors. If I use MBR, I get no errors in gparted, but Elementary OS won't install without GPT. Zorin OS and Linux Mint have no trouble.
    – Mitkins
    Jan 30 at 8:14
  • I tried to reset my hard disk partition with GPT (using gdisk). Still no luck. I'm wondering if it's because my BIOS doesn't (appear) to support AHCI? Also, I wonder if I could somehow clone the live CD to my SSD. Would that boot?
    – Mitkins
    Feb 7 at 22:49
  • The other thing I noticed is that Zorin OS and Linux Mint will display an error message at the partitioning stage (once) but then continue. Elementary OS will just stop in its tracks. I wonder if it's just coded differently
    – Mitkins
    Feb 7 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.