0

I've been trying to install elementary OS 5.1 for the past couple of hours with no luck. The installer keeps failing 2/3rds of the way with the following error message:

The installer encountered an error copying files to the hard disk:
[Errno 5] Input/output error

I'm trying to install elementary OS from a USB stick onto a fresh hard disk (bought the SSD today).

My system

  • Intel i5
  • 8GB ram
  • GTX 650 TI
  • the fresh 120GB SSD (previously working components). ISO filename: elementaryos-5.1-stable.20191202.iso

What have I tried to do:

  • I've tried to burn the latest ISO using both Etcher and Rufus, but with no luck. I've tried both ISO and DD versions in Rufus - no difference.
  • I've checked the hash, which matches up with the hash on the installation guide page.
  • I've tried to set up custom partitions when running the installer - tried both ext4 and ext3 partition settings.
  • I've tried to select the "Try elementary OS" option, and then running the installer from terminal with ubiquity

I am honestly at a loss of what to try at this point...

Please help :)

thanks in advance.

  • You check in your BIOS if you are UEFI or LEGACY? You are in AHCI mode? Can you add the log just before your errors for know when the error comming from the intallation? And can we know the model of your pc? – LinkPhoenix Dec 15 '19 at 0:59
  • @LinkPhoenix I'm not sure how I can check whether I'm on UEFI or Legacy. When I boot my pc it says "Press Del or F2 for UEFI BIOS settings". So I'm assuming EUFI? SATA mode is AHCI. I am not sure sure what log you want? From what directory? Pc is a custom build, motherboard is an ASUS B85M-G. – purplej Dec 15 '19 at 1:53
  • For check if you are in UEFI or Legacy mode go to the user manual dlcdnet.asus.com/pub/ASUS/mb/LGA1150/B85M-G/E8146_B85M-G.pdf , i would like loge before The installer encountered an error ... – LinkPhoenix Dec 15 '19 at 10:26
0

Solution

I had the same issue with Elementary 5.1(Hera) and tried the following things.

  • Downloading the iso again
  • Did hash check and found it's ok
  • Recreate the USB using Unetbootin, then Startup disk creator
  • ubiquity --no-migration-assistant
  • Restructuring partitions

But none of the above worked.

Finaly what worked was, i wrote the image to a DVD using Brasero and tried. It worked like charm.

I know it's wierd, but that simply worked. I have read this solution in other forums too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.