0

Before it worked in the beginning of Ubuntu 14.04 installation (same with Linux Mint Cinnamon 17.2) after hitting F6 and checking either one of:

acpi=off, nolapic or nomodeset.

Must be something with the HP BIOS since on my newer desktop PC (also with nVidia card) installation went smooth. There is not much to change there, though, just checking/unchecking UEFI.

Any clues, please?

Thank you, Marek

  • I meant, e OS, of course. Boot either from USB or DVD, same thing. – Marek Sep 13 '15 at 14:38
  • No, it's not about old BIOS. It's about the e OS installation package. I've tried now Ubuntu 15.04 installation on that HP, after checking nomodeset Ubuntu installation went ahead. Too bad, e OS is so simple and beautiful, er well... – Marek Sep 13 '15 at 20:03
0

Keep in mind that this is only a workaround!

Rob Hartley (8ob): This is only a workaround though. The real question is why this happens in the first place. I did not receive any errors during installation that would suggest grub failed to configure the system properly.


  • Install Elementary 0.3.1 as normal (no special partitioning).
    Follow: elementary.io - Installation

  • Boot will end in grub shell. Enter:
    configfile (hd and press TAB. Select one and add /boot/grub/grub.cfg
    Example: configfile (hd0, gpt4)/boot/grub/grub.cfg

  • Open terminal after boot and type:
    cd /boot/efi/EFI/grub
    sudo cp grubx64.efi grubx64.efi.backup (just in case)
    sudo rm grubx64.efi
    sudo cp /boot/grub/x86_64-efi/grub.efi /boot/efi/EFI/grub/grubx64.efi

Source: Freya UEFI install boots to grub prompt

  • " configfile (hd0, gpt4)/boot/grub/grub.cfg" - error file name – Marek Sep 14 '15 at 8:48
  • Are you serious? That was my answer to this: elementaryos.stackexchange.com/a/1884/1193 !! ?? – Tomblarom Sep 14 '15 at 18:10
  • 1
    @8m47x Answers posted on stackechange are licensed in such a way as they can be reproduced. In this instance, I'm not sure this is the answer to the question, but if it is it's the question that will be closed, not this answer. – Lewis Goddard Sep 14 '15 at 21:02
  • @8m47x should I have just linked your answer? I saw it on a couple other threads and didn't think too much of it. – josef Sep 14 '15 at 23:43
  • @Marek you have to choose the root partition you installed eOS to as you are aiming to point the grub to the correct config. – josef Sep 14 '15 at 23:44
-1

Rob,

I'm getting error after error, that's why I'll stick to Mint 17.2 on that HP notebook and I still have elementary OS on my prime computer.

Thanks anyway.

BTW Cinnamon Mint installation has one additional option: - Install in Compatibility Mode. This works.

Not the answer you're looking for? Browse other questions tagged or ask your own question.