2

I am new in linux environment. And after doing some research, I found elementary is the best user friendly OS we have. I installed the 32-bit version of it, and now I am trying to install VLC using sudo apt-get install vlc. I am unable to install it and receive the below error.

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 3.0.0~~git20150319+r59816+33~ubuntu14.04.1) but it is not going to be installed
       Depends: libavcodec55 (>= 6:9.1-1) but it is not installable or
                libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) but it is not installable
       Depends: libavutil53 (>= 6:9.1-1) but it is not installable
       Depends: libfreerdp1 (>= 1.0.1) but it is not installable
       Depends: libqtgui4 (>= 4:4.8.0) but it is not going to be installed
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
       Depends: libvlccore8 but it is not going to be installed
       Depends: libvncclient0 (>= 0.9.9) but it is not going to be installed
       Depends: libxcb-composite0 but it is not installable
       Depends: libxcb-keysyms1 (>= 0.3.9) but it is not installable
       Depends: libxcb-randr0 (>= 1.1) but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
       Recommends: vlc-plugin-notify (= 3.0.0~~git20150319+r59816+33~ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 3.0.0~~git20150319+r59816+33~ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried searching in net, I tried executing sudo apt-get update/upgrade. added vlc repository. But still I am getting this error.

Please let me know how can I fix this.

Thanks.

  • Do you have Ubuntu restricted extras installed? – Duarte Mendonca Sep 17 '15 at 3:50
  • No, i tried installing but i got the below error. The following packages have unmet dependencies: ubuntu-restricted-extras : Depends: ubuntu-restricted-addons but it is not installable Recommends: ttf-mscorefonts-installer but it is not installable Recommends: unrar but it is not going to be installed Recommends: gstreamer0.10-plugins-bad-multiverse but it is not installable Recommends: libavcodec-extra but it is not going to be installed – Ajay Sep 17 '15 at 4:45
  • @Ajay , Could you add output of grep "^[ ]*deb " -r /etc/apt/sources.list* ; echo q | aptitude -s install vlc ; apt-get -s -o Debug::pkgProblemResolver=yes install vlc , you may upload it to paste.ubuntu.com – user.dz Dec 11 '15 at 19:53
2

Try removing vlc with:

sudo apt-get remove --purge vlc*

after that you will need to remove ppa that you have added: Install ppa-purge:

sudo apt-get install ppa-purge

You need to know what ppa you have added I pressume it's ppa:videolan/stable-daily but you need to check the exact ppa in the bash history:

cd
scratch-text-editor .bash_history

When you find ppa use following commands (if you added different ppa just replace ppa:videolan/stable-daily with your ppa).

sudo ppa-purge ppa:videolan/stable-daily  
sudo apt-get update

Reinstall VLC:

sudo apt-get install vlc

This should help, if not read this post

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.