0

Weird bug persistent for a few days now - my Appcenter (including all notifications) is now in French

screenshot attached

I have never used French as my OS language, nor am I located/have travelled to that region. I use English (UK) and am located in Slovakia.

The rest of the operating system respects my system wide language settings/preferences (which is English UK - and I have tried to change this to something else and back again but the problem persists)

I have also tried to purge my appcenter and appstream packages and reinstalled, but no luck there either.

Any ideas about what might be going on?

Many thanks!

UPDATE: I managed to get it back to english by using synaptic to force version from the stable repositories (rather than daily) - now the issue seems to be that no apps show up (either from the elementary app store or the normal repositories - but I have had this issue before and usually some combination of purge and reinstalling appstream from either the daily or stable repository fixes it)

So I guess this was just some weird issue brought on by myself, as a result of using the daily repositories...

2

This was an issue with someone mistakenly entering French translations into the translation website. This only affected the English (UK) translations, US English was unaffected.

These changes have been reverted and the issue should now resolve itself automatically over the coming days.

See here for the bug report on GitHub where the issue was tracked down and fixed: https://github.com/elementary/appcenter/issues/481

-1

Edit: David Hewitt is correct in his comment;

This issue was nothing to do with appstream and appstream doesn't control the language in which applications are displayed either. This answer is more likely to cause issues in the future when later versions of appcenter come along that depend on the fixes in the version of appstream that elementary ships

I am leaving this answer for the odd time it may help. Use this fix with the above information in mind.


The updated Elementary appstream is sometimes weird. I ended up putting a hold on mine and it solved some quirks.

Try to install the Ubuntu appstream then hold it from updating.

sudo apt policy appstream

sudo apt-get install appstream=(ubuntu version)

sudo apt-mark hold appstream

That fixed it for me.

  • 1
    This issue was nothing to do with appstream and appstream doesn't control the language in which applications are displayed either. This answer is more likely to cause issues in the future when later versions of appcenter come along that depend on the fixes in the version of appstream that elementary ships. – David Hewitt Sep 16 '17 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.