0

I updated my packages with Synaptic, and when I open the AppCenter i first get a "Failed to fetch updates" error message. As I understand from the other errors messages, this has something to do with faulty repositories. Here are mine :

W: Le dépôt http://archive.canonical.com/ubuntu loki Release n'a pas de fichier Release.
W: Les données depuis un tel dépôt ne peuvent être authentifiées et sont donc potentiellement dangereuses à utiliser.
W: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Le dépôt http://ppa.launchpad.net/moka/stable/ubuntu xenial Release n'a pas de fichier Release.
W: Les données depuis un tel dépôt ne peuvent être authentifiées et sont donc potentiellement dangereuses à utiliser.
W: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Le dépôt http://ppa.launchpad.net/versable/elementary-update/ubuntu xenial Release n'a pas de fichier Release.
W: Les données depuis un tel dépôt ne peuvent être authentifiées et sont donc potentiellement dangereuses à utiliser.
W: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: http://ppa.launchpad.net/moka/stable/ubuntu xenial/main amd64 Packages is not (yet) available (403 Forbidden)

I apologize for the language, but oddly enough when I try to change the system language and recreate the issue, I get "Failed to obtain authorisation" instead of the repositories list.

Apparently, all repositories listed do not have 'Release' files. Could it be because of the Switch to 5.0 ? I'm currently running 0.4.1

0

You have two problems here.

The first is that something has happened to your http://archive.canonical.com/ubuntu repository as it has loki as the release codename when this should be xenial.

You will need to replace all instances of loki with xenial in /etc/apt/sources.list and the files within /etc/apt/sources.list.d. See another of my answers here for more information: https://elementaryos.stackexchange.com/a/15236/9699

The second issue is you have some PPAs enabled that aren't compatible with loki or that don't exist anymore:

  • versable/elementary-update is not loki compatible
  • moka/stable doesn't exist anymore.

So removing both of those PPAs from your sources files should also help resolve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.