0

So small issue here.

After installing updates the App Center doesn't display any updates see screen-shot.App Center Updates Tab

If I run the command 'sudo apt upgrade' I get the following output:

The following packages have been kept back: appcenter appstream libmaya-calendar0 libscratchcore0 maya-calendar maya-calendar-plugin-caldav maya-calendar-plugin-google scratch-text-editor 0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

If I run 'sudo apt update'is successful

I can also install apps via terminal.

If I try install an app via App Center it just hangs saying starting it doesn't even ask for authentication.

Anyone fix this error themselves? It occurs on three different machine of mine.

Thanks in advance.

  • I have the same problem. I installed elementary OS yesterday. The only way that is possible to get new softwares and updates is using apt-get in the LINUX Terminal. I wanna use the AppCenter. – Joao Paulo Druzina Massignan Apr 14 '17 at 13:28
0

I had this problem too with a new installation on an older Dell laptop. Once I used apt to 'update' and 'upgrade' and rebooted the AppCentre had everything in the right place (when looking at "Upgrade") and my issues of installations being stuck on 'started' was fixed as well.

Open a terminal and start with:

sudo apt update

Once that's done do this:

sudo apt upgrade

and then reboot

sudo init 6

After the reboot go back into AppCenter and check the Updates. Also try to install an application. It should work now.

  • It worked thank you purely from an educational stand point if I may ask why did it work? Reason I ask is I have run sudo apt update as well as sudo apt upgrade before and rebooted via the start menu and this didn't fix it so my theory is it has something to do with sudo init 6 so I'm just curious why. – Aeon Apr 15 '17 at 10:04
  • @Aeon because this was an issue that was fixed less than 24 hs ago: github.com/elementary/appcenter/issues/215 – Gabriel Apr 15 '17 at 15:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.