0

When trying to update from the AppCenter I get this error, with the text "This may have been caused by external, manually added software repositories or a corrupted sources file."

These are the details:

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:56 and /etc/apt/sources.list.d/appcenter.list:1
E: http://pt.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 DEP-11 Metadata is not (yet) available (Could not open file /var/lib/apt/lists/partial/pt.archive.ubuntu.com_ubuntu_dists_xenial-updates_restricted_dep11_Components-amd64.yml.gz - open (13: Permission denied))
E: http://pt.archive.ubuntu.com/ubuntu xenial-backports/main DEP-11 64x64 Icons is not (yet) available (Could not open file /var/lib/apt/lists/partial/pt.archive.ubuntu.com_ubuntu_dists_xenial-backports_main_dep11_icons-64x64.tar.gz - open (13: Permission denied))

Before I have had problems trying to update both from the AppStore and terminal, but it was, according to the help I got, with the kxstudio-debian and nathandyer/vocal-daily.

Can you please help me solve this?

Thank you in advance.

1

It looks like there are two different errors here:

  • The first is that it looks like the AppCenter has been added twice. I'm not sure what has done this, but apt doesn't handle the same repository being configured twice very well. It's configured once in /etc/apt/sources.list on line 56. And once in /etc/apt/sources.list.d/appcenter.list. The original/correct place for this is the /etc/apt/sources.list.d/appcenter.list file, so I would recommend removing the AppCenter line from /etc/apt/sources.list
  • Secondly, it looks like apt is having some issues writing some metadata due to Permission denied errors on two files. It may be worth trying to remove these with the following command (they should be automatically re-downloaded on the next apt update):

    sudo rm /var/lib/apt/lists/partial/pt.archive.ubuntu.com_ubuntu_dists_xenial-backports_main_dep11_icons-64x64.tar.gz /var/lib/apt/lists/partial/pt.archive.ubuntu.com_ubuntu_dists_xenial-updates_restricted_dep11_Components-amd64.yml.gz

  • Thanks for your advice. I migrated to the new AppCenter when it was first released. I supported it from the start. And maybe I made somthing wrong then. Anyway, I now have a fresh install of Juno, so this is not a problem anymore. This thread can be closed. – hainish Dec 5 '18 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.