1

I am a new user of elementary OS, but I have messed around with various different Linux distros for s few years. My question is quite simple, I need to change the Grub menu to have a different OS (Windows 10, sorry) load first. What I mean is that right now elementary OS is the first OS on the Grub menu, but I need Windows 10 to be the first OS in the Grub menu.

I have tried to add the Grub customizer but I can not seem to do that in elementary, although it has worked in other distros in the past.

Any help would be appreciated.

Thanks, Rocky

3

There is a file /etc/default/grub You may change a line there, saying

GRUB_DEFAULT=0

Uncommenting and changing it to

GRUB_DEFAULT=SOME_NUMBER

will change the default line in your grub screen to the "SOME_NUMBER+1". So if your windows 10 line is the 2nd then you need GRUB_DEFAULT=1

To do this it is better to make the backup of the file, change the line and update grub. The commands are:

sudo cp /etc/default/grub /etc/default/grub_ORIGINAL_BACKUP

sudo scratch-text-editor /etc/default/grub

change the line and then

sudo update-grub

The windows line will stay where it was, but will become default.

  • Thank you very much Evgenil, I performed those steps exactly the way you indicated and it "kind of" helped. The process did change the boot order somewhat, but now the Grub boot loader starts on the second line, which is advanced options for elementary. I really need the Grub boot loader to start on the third line, which is Windows 10. – Rocky Bennett Mar 10 '17 at 10:22
  • So, the fact that windows 10 is the 3rd means that you need to use GRUB_DEFAULT=2. Try and, please, tell if it worked, or not. – Evgenii Frolov Mar 10 '17 at 11:39
  • Glad to help! Could you please mark the answer as accepted then? And why didn't grub-customizer worked? – Evgenii Frolov Mar 10 '17 at 17:51
0

This worked for me to get Grub Customizer installed.

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt update
sudo apt install grub-customizer
  • I have tried that many times, even before I asked here. This is what I get; rocky@rocky-All-Series:~$ sudo add-apt-repository ppa:danielrichter2007/grub-customizer [sudo] password for rocky: sudo: add-apt-repository: command not found rocky@rocky-All-Series:~$ – Rocky Bennett Mar 10 '17 at 14:40
  • where error is it returning when you try to install it via the PPA? It is possible, I've done it many times. – Sean Patterson Mar 10 '17 at 14:43
  • Yeah, I just don't know what is wrong with command, it has worked for me in Ubuntu and Debian, but it just does not work in elementary, as I have posted the results a few minutes ago. Oh well, the situation is corrected. – Rocky Bennett Mar 10 '17 at 14:53
  • Ok I know what the issue is, or I think I do. In elementary you can't install from PPAs out of the box. You need to run this command to allow it: sudo apt install software-properties-common python3-software-properties python-software-properties ---this will come in handy in the future even if you have the grub issue resolved. – Sean Patterson Mar 10 '17 at 14:57
  • 1
    Thank you very much. Yes, that information just might come in handy in the future. Thanks again for helping me out. – Rocky Bennett Mar 10 '17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.